Character Count is not exact?

Dear Keith,

I am confused about character counting.
The output of <$cc> is 537.176
When I summarize the characters in the outiner, I get 536.545
(maybe that’s because of my brain…)
When I count the text in Word, word says: 531.882

So have I lost something during the export process?

Thanks for your Feedback
Best regards
Mira

What do you mean by counting the text in Word? With spaces or without?

The output of <$cc> will be all the characters that are in the compiled draft. The characters counted in the outliner won’t be able to take into account extra characters created by including titles, adding page breaks and so on in the compile process, so won’t be exactly the same.

Hope that helps.
All the best,
Keith

Dear Keith,
thanks for answering fast.
It helps to calm down.

In the meantime I exported twice:
export as .doc, then counted by Word (with spaces): 536.415
export as .rtf, opened in TextEdit and copy/paste into word, counted by Word: 531.977
variable <$cc> says 537.035

I have problems exporting as .doc (styles, indents get lost, Highlights resist) so the best way to export to Word (at the moment for me) is to export as rtf and copy/paste it via TextEdit into Word.

Maybe rtf counts spaces/line breaks different??

? I’m not quite sure what you mean by this, please explain? :open_mouth: My answer was considered and I helped as best as I could given the limited information you provided.

The best way of exporting to Word is as RTF - you can open RTF files directly in Word.

There are all sorts of things that could be at play, so it is difficult to tell you the reason for this without more information. For instance, does your document have footnotes? If so, these would be counted but TextEdit would trash them.

It’s also important to understand that things like word and character counts will vary between applications - Word’s character counter does indeed seem to be slightly different to the one the OS X text system uses (which is what Scrivener is based upon). For instance, I just pasted a document of 24,810 characters from Scrivener into Word, and Word counts only 24,611 characters. It seems that Word doesn’t count the line breaking characters, so for every return character you have in your document which is counted by Scrivener, Word will return 1 less character.

I hope that clarifies things.

Regards,
Keith

Oh! Sorry for my bad english. I wanted to say, your answer helps me to keep cool instead of worrying that much about the thing. I really thank you.

So the difference comes from

  • footnotes (which I have)
  • line breaking. Word counts apprx. 5000 Paragraphs in my document – there are my characters :smiley:

Best regard,
mira

PS: When I insert the rtf directly into Word, I lose some indents. I’ve found out it works better when I paste the rtf in a new Word-document than in my used manuscript.doc (maybe I already messed up my styles there) but only the workaround with TextEdit keeps all my paragraphs/indents and trashes the highlighting.

Ah, sorry, I misunderstood! I thought you were telling me to calm down and that I had accidentally come across as rushed or annoyed or something else unintended! The perils of non-face-to-face communication… :smiley:

Regarding formatting problems, here are some things to bear in mind:

• TextEdit and Scrivener use the same RTF and DOC exporters, so you shouldn’t really be seeing a difference. However, Scrivener uses an enhanced version of the RTF exporters (to add support for footnotes, images, headers and footers etc), and it also uses RTF under-the-hood for DOC exports if a document has footnotes, images or a header or footer.
• The standard Apple .doc and .docx exporters mess up line spacing, so it’s usually best use RTF.

One thing to check: Go to Text > Show Invisibles in Scrivener to check your line breaks. Are the line breaks at the end of each paragraph represented by a down/left pointing arrow, or by the standard paragraph marker (the “|P” sort of mark)? If it’s the arrow, it may be that you have been hitting shift+return instead of return after each paragraph, creating a line break rather than a proper paragraph break, which could mess up the formatting in Word.

But yes, you are absolutely right about the difference - footnotes and paragraph markers. I had no idea until now that Word didn’t count the paragraph break characters in its character count, to be honest.

All the best,
Keith

Miralda,
Only [size=150]geniuses[/size] and [size=150]gods[/size] like [size=150]the Amazing[/size] Blounty would have taken your words to mean anything other than what you intended. There is absolutely nothing wrong with your English, Its perfect. :wink: [size=150]Young tremendously-brilliant-person[/size] is acting up because hes a knew Dad, and his Good lady and children expect him to take care of them. Obviously this extra responsibility is taking its toll.

When he gets like this we just feed him some of these.
Take care Mira
Fluff
Unknown.jpeg

OK, I’ve read it again – now I’m knowing what I REALLY wanted to say, it is, of course, that the faster someone answers the calmer he gets :wink:

I share one cracker with you. (If you want to.) You’ve solved my question completely, thanks a lot. Now share your time with your family :slight_smile:

Best regards,
mira

(The paragraph are standard, no arrows.)

That’s good that the paragraphs are standard - although I’m confused about the formatting problems now. If you can give me more information about what the exact formatting differences are, I’ll try to help you resolve it.

As for vic-k, he is determined to spread the word through these forums that I am a grump, just because I occasionally use my mod powers for evil and alter his posts. :slight_smile:

All the best,
Keith

I can, and do, rise above it. [size=50]Frequently![/size]

Dear Keith,

Sorry for me answering late. I had to finish my stuff - but now I have exported again and have tried to document it:
In Scrivener, I use Courier New 12 pt. This is what happens:

alternative 1: Export to rtf > open with Word X
= font changes to „CourierNewPSMT“ (wrong, looks like Times)
(left indent + sometimes italic is okay)

alternative 2: Export to rtf > open with TextEdit
= still Courier New (fine) + Highlights remain (not fine)
BUT > copy/paste into manuscript.doc
= CourierNewPSMT (wrong), wrong spacing

So, no matter whether I open it with Word or with TextEdit, at the moment when it has to go into Word the font changes in this strange CourierNewPSMT (which I even don’t have on my mac???). I have to change it manually into Courier New, adjust spacing, set right indent to zero. That works fine for me. I would love to keep the styles but I understand that this is a problem of the apple rtf engine.

Little problem in general:
= sometimes ^p^p^p instead of ^p^p between files (yet in rtf)
(> search and replace)

So it needs a little bit of adjustment after exporting, but that is okay. You don’t have to examine this if you don’t have time or your own curiosity :wink:

Thanks for this nice Scrivener!!

Best regards,
Mira

I’ve found out a workaround: In Word go to Preferences, Compatibility > Font Substitution. There you can permanently replace the PSMT with the normal Courier New. (It was set to Times…)

When you close the rtf and open it again in Word, the font is still PSMT, but displaying as Courier New. Spacing is correct.

I have known for ten years that Word is a strange app. So why wondering :wink:

Hi Miralda,

Many thanks for sharing the solution for getting the fonts to show up correctly in Word - this has bugged me sometimes, too. Times New Roman sometimes goes across as TimesPSMT, for instance. I think the problem is that Word uses different versions of the fonts entirely to the rest of OS X, so sometimes it ends up substituting ones that aren’t quite right.

If you can find a case where the triple return comes out as a double return in such a way that you can tell me how to reproduce it every time my end, let me know, as that seems odd.

Thanks again and all the best,
Keith