Character spacing (kerning) inconsistent in PDF / Print output

I am a new Scrivener user, running version:, and I compiled my project to .pdf using the default “Manuscript (Times)” template, except I changed the font to Arial per reader request. The result looks like it was created by a drunk typesetter. The images below were captured from the pdf as viewed in Adobe Acrobat. Any suggestions?

Another screenshot.

Here is a .pdf created with Microsoft word using the same formatting for example.

Is that an Editor view or a Compiled export?

Compiled export direct to pdf. The screenshot is from Adobe Acrobat Reader.

Did you change the font in Compile or in the Editor? Does it look good in the Editor?

Interestingly enough, this seems to be a problem with the interaction between the version of Arial used by Windows 10 and the PDF generator. When I first tested this, it was from Linux, and the result was fine (not amazing, but it is Arial after all). So I rebooted to Windows and then got the same result you did. While there, I also checked with a different font, since I was getting different results, and found that Calibri seems to work much nicer. The two samples below are from (a) Scrivener and (b) LibreOffice. There are small differences between the two—for something that matters you would certainly want to use the latter, but to my eye the former is acceptable for proofing copies.

1 Like

I changed the font in the Compile. Everything looks good in the Editor (and I would never change the Editor font to Arial).

Thank you for the validation and testing, Amber. I agree Calibri works a bit better on Windows, and it’s good to know I can get a solid result with Linux (I’m one more excuse away from setting up a dual boot option).

Still… You can see the drunk typesetting problem persists even with Calibri (between the ‘k’ and ‘e’ in ‘backed’). It would be good to know the bug was flagged for a developer.

Scrivener on Linux is a mix of pros and cons. It obviously runs better in its native environment, and a few things don’t work well that some might consider essential, but on the other hand everything around Scrivener isn’t Windows… so there’s that. :laughing:

Still… You can see the drunk typesetting problem persists even with Calibri (between the ‘k’ and ‘e’ in ‘backed’). It would be good to know the bug was flagged for a developer.

There’s not much they can do about it regrettably. You could try adjusting the PDF output settings in the Editor: Options tab, File ▸ Options.... As I understand it, they have provided us with all of the tools they have available themselves, for tinkering with the quality of the text output for PDF in those settings.

1 Like

Amber, that was it!

I just switched the “Print & PDF Font Handling” from “Full Hinting” to “Default” and here’s the outcome (much improved):

Thank you so much for your help!

1 Like

Hi. It seems I have a weird problem when I compile my draft in PDF.
Most publishers here want Times New Roman PDF, double spacing.
Weirdly, my Times New Roman 12 pts output in PDF looks much weird to me. The letter spacing appears to be a bit off.
You can see a screenshot of a couple of line here. Even the line spacing seems weird to me (set at 2X).

Somebody had the same problem?

Hi all,

I’m a long time user of Scrivener but first time posted on the forums. I upgraded to Scrivener 3 for Windows when it was released and it’s fantastic.

I’ve been having a lot of trouble with the compile feature, though. When I use the Manuscript (Times) preset, the kerning (spacing between letters) looks squished. Unfortunately I can’t upload a screenshot to my post to show you what I mean.

I searched the forums and saw that changing the settings (under File - Options - Editing tab - Print & PDF Font Hinting) has fixed this exact issue for some, but I’ve tested a new compile with every option available in the “Print & PDF Font Hinting” setting and get the same result each time. I’m using Scrivener 3 for Windows on a HP laptop with Windows 10 (and now Windows 11).

The only way I’ve been able to get it to work is to compile to Word (.docx), which doesn’t have the kerning issue, and saving that file as a PDF or printing to PDF.

Compiling to Word and saving as a PDF is fine as a workaround, but I worry Word might crash with larger projects. I’ve only tested it with ~2,000 words, but my whole WIP is over 100,000.

Can someone point me in the right direction to fix this? Thanks in advance :slightly_smiling_face:

For those who started new threads on this, and had them merged to this discussion, refer to this comment for a known workaround.

Note that generally we do not recommend using Scrivener’s PDF output for anything other than proofing. For stuff other people are going to see, compile to RTF, DOCX or ODT, and either submit that document, or use a word processor such as LibreOffice or Word to generate the PDF. For publication level output, other tools entirely (such as Affinity Publisher, InDesign or LaTeX) are the best choices.