"Check Spelling While Typing" not working

I have the option enabled in “Edit” and also checked in Settings > Corrections > Correct spelling errors as you type. I unchecked, checked again and restarted before deleting Scrivener completely, coming to L&L and downloading/installing. Still, no red squiggles.

Anyone have any idea what the issue might be? I’ve never had this problem before and I’ve been using Scrivener for about three years.

1 Like

I am no Mac user, but this, I think, is the wrong option.
You’d want check spelling as…
image

Correct spelling as you type comes with no visual cue.

Now, your title conflicts with your content. I don’t know which is which, but if you only have “Correct spelling…” checked, that’s likely your issue. :wink:

2 Likes

Thank you! I think I understand what you’re saying :smiling_face:
so I unchecked “Correct spelling errors as you type” and I have “Check spelling while you type” enabled from the Edit menu but still no visual for misspelled words.

1 Like

Under windows, you need to specify a dictionary.
I don’t know how it works for Mac, but see if you have a place to set one here:

3 Likes

Wow, I don’t have those options in my menu. I really appreciate you sharing the pictures with me, though. I started to think I was completely off in the wrong menu or something but I’m in the same spot lol just missing some of the options.

I tried to share screenshots but my account is too new for uploading images :weary:

1 Like

You need assistance from a Mac user. I can’t help much further.
@gr @xiamenese @November_Sierra

I just called in some of the forum gurus. :wink:

1 Like

Thank you for your efforts, I really appreciate you taking the time to try. Also, huge thanks for tagging others in!!

2 Likes

Might sound like a stupid question but, did you actually misspell a word ?

1 Like

It does on the Mac (with “Edit → Spelling and Grammar → Check Spelling While Typing” checked, no matter what the setting under Preferences says):

The actual “dictionary” settings (which language or automatic by language, etc.) is located in the macOS System Settings (under keyboard, input methods, etc.)

1 Like

@November_Sierra : you missed the difference between “check” and “correct”…

You quote me saying “correct” but you replied to “check”.

1 Like

Ugh. You’re right. My bad.

1 Like

Yep, I did. All of the other selections in that menu are working so I’m very confused. I typed “delecate” and hit space bar. It capatalized the D but no visual clue of misspelling.

1 Like

Could be an OS setting…? Nothing to do with Scrivener ?

Here, perhaps:

1 Like

I thought so too… went and checked around but mac settings look good to me. To be sure I opened Pages and typed a few misspelled words and got red lines but I’ll go back to keyboard as suggested. Thank you, @November_Sierra!

2 Likes

As stupid as it sounds, did you try restarting you computer? Sometimes those mysterious hiccups just disappear after that.

2 Likes

Not a stupid suggestion at all, that’s exactly what I’m getting ready to do. It’s my go-to when I find myself at an impasse! We’ll see :crossed_fingers:

2 Likes

Still nothing lol! I guess I’ll just have to check manually. So weird because this has never been a problem. Thanks again!

1 Like

Weird. Could you try it in TextEdit? That’s using the same text engine as Scrivener. Just to rule out if this is a Scrivener specific issue.

1 Like

I’m using Scrivener for Windows v.3, and I can’t find the settings button. I can only find Print Settings. Where is the settings button located? I’m having the problem that it is showing me misspelled words but not correcting them as I type.

Can I make a left-field general comment?

If something seems not to be working as you expect in Scrivener, checking in Pages is not going to help. Pages uses a totally proprietary text engine to the extent that Apple doesn’t let any other app read Pages documents.

You need to try in TextEdit or any of the other apps based on the text kit used in Scrivener… Mellel is not one of them.

Over the years there have been many comments on check spelling suddenly stopping working in Scrivener. I have it turned off completely and spell check post compile in Nisus Writer Pro.

Mark

1 Like