Chinese characters / screenplay problem

I’m using version 1.11. I opened an old project which contained no documents (because I had deleted what I was working on before saving and closing) and for whatever reason, Scrivener came up in screenplay mode, but there was no checkmark by the “Script Mode” menu item. When I started to type Chinese characters, each new word appeared with an extra pinyin letter in front of it. TextEdit can handle Chinese characters with no problem, and in a normal document (not Script Mode), Scrivener works just fine, too. After some experimentation, I found that it is the Scene Heading style which interferes with the Chinese (ITABC) keyboard. I did not intend to be in Script Mode, so I “fixed” the problem by closing and re-opening Scrivener. It came up in its normal mode the second time. I used SnapzPro to make a movie showing how to duplicate the bug, so just let me know if you want me to send it in. Thanks!

An allied problem – allied since it is to do with Chinese – is that on importing a windows .doc file in Chinese, it apparently comes up blank apart from any roman characters, numbers, etc. Very disconcerting.

It’s not actually Scrivener’s problem but Apple’s because of having to drop song.dfont with 10.4 through postscript conflicts. Using the “Convert to Default Text Style” or highlighting the whole text and switching to one of the available fonts brings the text back.

The default Simplified Chinese font – under 10.5.1 – is unfortunately STHeiti – which I think is Apple’s default, though that’s better than Hiragino Mincho Pro, which it used to be! – and I wish there were some way of changing it in the preferences, but Keith has got more important things to do this year than playing about with how to set default secondary CKJ fonts!


cjenkins - definitely send me the movie. To (make sure it’s not too big, though - not over 10MB).

Keith, sorry it took me so long to reply. The system did not alert me that the forum was updated and I only just checked back in. I can send the movie, but its about 23 MB. Do you have any way to accept a file of that size?

Ouch. Is there any way you can compress it any more? My e-mail should accept 23MB, I think, so try sending it if you can’t make it any smaller.

Okay, I tried emailing it. My stupid email server always says large emails fail, but they usually go anyway. Please let me know whether you get the movie! Thanks!

I’m afraid I didn’t receive it, no. :frowning:

Arrgh! I’ll have to see if iMovie will let me edit it down. I’ll be out of town for a few days, so it will be another while. Sorry to be so much trouble!