Choppy Scrolling

Hey guys,
I recently setup my new MacBook Pro (2017 model) and noticed the scrolling is not as smooth in Scrivener as other programs. It’s not terrible, yet every other app glides (safari, word, notes, etc.) The scrolling seems even choppier in the full screen Compose mode. All the scrolling is being done with the trackpad.

Anyone have any thoughts?
Many thanks!

I’m on a very similar MacBook Pro myself, and the scrolling performance is very smooth right now (I’m even running Windows at the same time in a virtual machine). There are a few things you can check:

  • Performance: are you running a lot of stuff, or is there one program that is using a lot of resources in general? Activity Monitor can help with this.
  • If you haven’t rebooted lately, do that. If that doesn’t help, try logging out of your account and then back in, holding the Shift key down as soon as you enter your password and click the button to log in. Keep it held down until fully logged in to inhibit any background software (Dropbox, etc.), then see if the problem persists with only Finder and Scrivener running. If it doesn’t, then start running your normal programs until the scrolling performance degrades.

Hi Amber,

Thanks so much for the response. Sorry for the delay in getting back to you. I see similar scroll performance after a restart / no additional programs loaded. Part of my full screen issue had to do with a background image. Once that was removed, I regained some performance.

To clarify my scrolling observation a little, the movement of the page feels pretty smooth, but definitely not as responsive as a safari window. Scrolling in a browser (or any other program) feels more directly mapped to the trackpad while scrivener feels more like a less sensitive interpretation of the swipe motion. Almost as if the swipe is getting filtered.

Do you feel like your scroll is identical to a browser window? Thanks again, and sorry if I sound like a crazy person. :smiley:

I just put 70,000 words into the text editor and scrolled around a bit in Scrivenings mode (around 70 files involved). I wouldn’t say that scrolling was awful—maybe a little slower than a web page—it’s an entirely different kind of program though, so I’m not sure how useful that comparison is. I would say the scrolling is more comparable to the same text pasted into TextEdit. Not quite the same context to be clear (one buffer vs several, one file vs 70, a complex split view window vs one, and so on), but at least that is use the same basic technology.

Maybe check the features you have running in the window. Anything that is adding a lot of dynamic data to the editor could possible slow it down. Lots of misspelled words with spell check while typing is enabled, invisible characters, line numbering, etc. And yes, good catch with the large graphic—optimising that to a smaller JPEG might help.

Thanks Amber,

I poked around a bit more and noticed that long documents (say a Scrivenings view of several pages) scroll as I would expect. Not quite at the same “frame rate” as other apps, but I can cover considerable distance in a single swipe. On short pages however, the scroll is heavily filtered. Almost to adjust to the shorter page length–which makes a bit of sense. That seems to be culprit.

Thanks for taking a stroll with me down the inner workings of the scroll behavior. Much appreciated!


Yeah no problem! Maybe the fixed-width option is the source of the slowdown. Try going into the Editor preference pane and in the middle right, disable “Use fixed width”. I got better scrolling performance in a normal window than I did in Full Screen, but when I disabled the “Full screen only” checkbox so that fixed width was used in a standard window as well, scrolling got a little choppier.

Good news is that on the same equipment, running the beta version of Scrivener, this problem seems gone with or without fixed width.