Collapse/Expand All

Running Scrivener 1.9 under Windows 7 Professional 64 bit.

View | Outline | Collapse All (and expand all) do not seem to work for me. I seem to remember using these successfully in the binder, but now - nothing.


The focus must be in the binder for the command to work there. It’s behaving correctly for me under 1.9, although I’m currently using Windows 10–I don’t think that’s likely to make a difference, though. Are you selecting the command from the menu or using Alt+[ and Alt+]? There might be a shortcut conflict if the latter, in which case customizing the shortcuts under the Keyboard options should fix it.

Thanks for your help.

The focus is on the binder. Menu options for collapse and expand do not work. Neither do the respective shortcuts. This happens with all of my Scrivener projects. I am sure (well, pretty sure) this worked prior to 1.9.


In that case, you may want to try uninstalling and reinstalling to see if that clears it up, since it seems to be specific to this installation. (I’ve tested under Windows 7 now too, so it’s not just an OS version problem.) You can save your program settings via the Manage menu button under Tools > Options, then reload them after you’ve done the fresh installation.

The inability to collapse and expand the binder seems to be related not to the installation but to the projects. To double check, I did an uninstall and reinstall with the same results.

  1. All my existing projects will not collapse/expand whether I use the menu or shortcuts.

  2. New projects behave as expected.

Now here is the interesting thing. After creating a few more new projects and confirming that collapse/expand works in all of them, I closed Scrivener. I later restarted Scrivener and my default project opened. Collapse/expand is now working in this and other files in which it was not working earlier.

I don’t know if this will last, but for now it appears “fixed.”


Wrote too soon. My discovery that this does NOT work in previously existing projects holds. However if I have another session of Scrivener running with a new project, then I can collapse/expand older projects. But only if I have a new project open.


Well that is extremely peculiar. Would you be willing to send a zipped copy of one of the non-expanding/collapsing projects to AT literatureandlatte DOT com? I can’t imagine what might be causing it, but taking a look at the binder file directly might reveal something.

Done. Please let me know what you find.


Thanks, Jon. It looks like a problem with the ui.ini file (in the .scriv folder’s Settings folder). If you remove that file from the problem projects, Scrivener will recreate it with the default settings when you next open the project and the expand/collapse should work properly in the binder. You may need to reenable options like View > Use Label Color In to restore the project’s previous appearance.

Thank you for this information. Since this is confined to projects updated by 1.9, can I infer that there is a glitch in the conversion? I ask this so I can know to repeat this for other projects not yet opened by 1.9.

EDIT: Sorry for omitting the most important piece - it worked! Thank you.


This is the first case I’ve seen of this happening, so I can’t say for sure what caused it. If you have one of the 1.8.6-format backups from a project demonstrating the glitchy behaviour, you could send that zipped as a reply to the earlier email and we can test the update process. If there is a bug in updating, that would help us fix it for the next update.

I will have to see which if any of my remaining unconverted projects can be shared. They may contain information that is required by law to remain protected. If I have something appropriate, I will send it to the address you provided.

Thank you again for your help.