Comics Script: two different elements (Character and Dialogue) on the same line

I need Character and Dialogue to be on the same line, separated by a tab, and not on a new line. How can I change the formatting to allow that? The default “spacing” under Script Settings only goes down to 1, and doesn’t allow 0. Not sure allowing a 0 would work, but I need a way to get Character and Dialogue separated by a tab and not by a line. One other person asked this question 7 years ago and didn’t get any reply. Thank you.


This should put them on the same line.

Thank you for your help. It does put them on the same line, but it changes the Character to Dialogue and then if I go back and change it to Character, it changes the following dialogue to Character, so there isn’t a way, that I’ve found yet, to have them remain separate from each other and inhabit the same line.

Are you trying to do something like this ? :


That is a single element, named image

If it is not currently in your script settings, you can see how it is set in the UK Stage Play.

(I’m far from being an expert in script mode (I think I even got my first post all wrong), but as far as I can tell, there can’t truly be two elements on a single line. That’s as close as it gets to it.)

1 Like

Yes. That’s it! Now I have to figure out howI replicate that option on the comics template. Or I may just have to modify the UK template. Thanks.

1 Like

I don’t know how. (I’ve checked the different options and there doesn’t seem to be any import/export functions.)
But, worse case scenario, create a dummy project that you can set to stage play and take screenshots of the different panels for that “Character & Dialogue” element.
Then add an element to your current script setup, and reproduce. (?)

1 Like

So for the sake of keeping a record to help others, I tried to replicate the character & dialogue element from the UK script into the Anthony Johnson’s comics script, but it will not work the same way. What I’ve done for now is modify the elements on the UK script to be comic elements instead, so far, that’s the only thing that has allowed me that functionality. My guess is somewhere in the layouts, there must be a setting that allows for elements on the same line that I just haven’t figured out how to access yet. Hopefully, that will answer some questions for others and if anyone figures out how to fix it, please let me know. Thank you, Vincent for all those tips, btw.

Hold up, I may have fixed it. I had my indent settings different for character &dialogue on my comics page than the one of the UK script page, so when I fixed that to be the same, the functionality appears to be working the same now on my comics script. I basically went into script settings and copied all the settings into a new character & dialogue element in my existing comics document and that seems to be working as of now.

1 Like

Nope, still not working. The tab feature after writing the character does not function the same as it does in the built-in UK script, so back to square one.

Are you positive you accurately, down to the detail, reproduced at least the first three tabs of the “Character & Dialogue” element in your comics script format ? As in everything ?

I don’t see why it wouldn’t work.

(Btw, I run the Windows version, and we have four tabs. The fourth being auto-completion, which shouldn’t matter.)
[EDIT] Although I just saw that there is an auto-completion setting to automatically go to the next line after a completion, so that might play a part…

Also make sure you are in the right element when trying it out. You can see that at the bottom right corner of the editor.

Yep. Just double checked. I’m going to see what happens when I import the document I set up with the UK script I modified.

Don’t forget to backup your project before risking messing it up. (Just sayin’. In case it slipped your mind.)

1 Like

What is it that isn’t working with the new element you’ve created in the comic template? The main things are:

  1. Font pane: set any formatting (for the character part of the line) to style to First tab.

  2. Paragraph pane: set the same measurement for the left indent and the first tab, something reasonable with whatever you set as the first line indent so that there’s room on the line to fit the character name before that tab stop. UK Script formatting has 0" first line indent and 1.5" for the left indent and tab.

    This is the one I’m guessing might be causing the problem for you, because if the text extends over that first tab mark, pressing tab will cycle you around to the next line. You can address that somewhat by clicking the Options button in the lower right of the Paragraph pane and setting a minimum number of tabs per line, but you’ll probably still want to put a larger indent/first tab amount if you’re typically not able to fit the text you need there. View ▸ Show Ruler in the editor might help you figure out what you need.

  3. Under Tab/Return you want Tabbing after typing to insert a Tab character, which you can do by pressing Opt+Tab on the keyboard. You can also add anything else here you want, like a colon before the tab.

Thank you. This whole thing just gets weirder. I double checked all of those items, all good, checked the ruler and that’s where the problem was. I fixed the ruler on the old Anthony Johnson script and it kept everything on the same line as long as I was correcting already existing dialogue, but when I go to insert new character and dialogue, instead of tabbing on the same line, it again, tabs to a new line. I check to see if the settings and ruler were different but they appear to be the same. I double checked the tab/return pane to make sure it was the same as the other script and they were (I even tried changing it to go to character&dialogue on a tab but that didn’t work either). To get the same functionality on new entries, I have to copy and paste an old one and then paste the new dialogue over the line I pasted but I can’t replicate the same functionality on new entries in the Anthony Johnson script. I don’t have that issue on the UK script, however. New entries are fine.

I went back into the script setting panes and although the “allow tabs” isn’t selected on the UK script, I selected it for the Anthony Johnson script and it seems to have fixed the previous issue. We’ll see if that continues. Thanks to everyone who has helped.

That certainly is curious. There’s nothing in the UK Script settings or template that can’t just be recreated from scratch, so it should be possible to make a new element in a different script format that works the way you want. If you’d like to share a copy of the settings you’re working on, either on the forum or sent to, I could take a look. (Go into Script Settings and use Save to File... from the Manage dropdown button in the lower left and then just zip and share that file.)

Thanks. I’ve uploaded a copy of the settings: Comic Book (Antony Johnston) modified with UK (1.6 KB)

Hm. The settings supplied work fine for me with the “Allow tabs” deselected and a Tab character added back into the Insert line for the Tabbing after typing behaviour. I tried creating a new project from the comic book template and importing them to that (then making those changes) in case there was something in the set up of the template that might’ve affected this, but new Character & Dialogue text is still being creating the tab stops on the ruler (per the script settings). If I’m understanding correctly, that’s what isn’t happening for you?

Yeah, for whatever odd reason. Once I changed the Tab/Return pane to Allow Tabs, that fixed it on the AJ script, but it’s definitely not working the same between the two templates, i.e. the modified Anthony Johnson script and the UK script (which I also modified but only changing the names of the elements).