'command T' does not always place the Font box in same exact place on the screen

Hi
I am a bit confused. I use Scrivener 3.1.3 on my iMac 27-5K running MacOS 10.14.6 it works perfect. To help my fingers and mousemovement I rely quite a lot on macro’s using Keyboard Maestro. this too works fine… and… since maybe 4 weeks ago one particular macro give crazy results. After many iterations and theories not giving result, I have found that
when I / or the macro use the ‘command T’, the resulting font box may not be placed exactly as before. there seems to be a jitter of about +/- 4 mm. How do I know? well I put a piece of tape on my screen and marked the varying sweet-spots.

and this macro is simply run to do just 2 things: first text is selected in the document, then it is made into title line by the ‘option command shift T’ combo and the the size is set to 36!.. this has worked for more than a year. now it may not.

So this is the description! Now how do I fix this?.. further to the problem comes that I use two languages, so in between the command t will evoke the Danish version, which by the way does not hold exactly the same outer dimensions.

The font box is evasive since it belongs inside Scrivener shave not been able to locate and define a ‘picture’ of the post I want to hit.
Would be great if someone in the forum have a useful (and solid) hint

I attach 2 screencaptures one is danish the other is English

Palle


Probably a Mac OS behavior. Check the same thing with Text Edit to confirm. – Katherine

I checked with TextEdit and in the trial I made the ‘Font’ box was substituted by ‘Skrifter’
giving an offset of sweet spot like: horizontal +27 pix and vertical +35 pix which is huge clickwise

Since the Fontbox is disappearing when I click to edit macro, I chose from the Start to put tape on screen to mark the location and then used the ‘get’ option from the macro. I dared this because at that time the font box was placed at same- rock-solid-position EVERY time
In all other macros I have used the ‘graphic recognition option’ over the easier ‘just click here’ because then the scrivener window may be at large on the screen.
I also suspect its a MacOs thing which could connect somehow to the use of darkmode or not. And possibly also the fact that ‘command T’ can be / is used in many other situations, like in Finder, Safari… so no wonder I get baffled when my screen suddenly erupts in strange windows selections instead of just setting the font to 36
for now I keep the tape onto the screen :slight_smile:

One more thing… :wink:
today I also discovered that the ‘Font’ box is not totally anchored in its lower righthand corner of screen. It seems that if you drag it to a new position, this placement will be remembered by system… hmm in that session… good to have the tape on screen for placement…
but it is really kind of stupid/ waste of time to try to tame this error… so will anyone have some workable steps for this action ( I do not use or understand ‘scripts’):

start
select text
select font to 36
apply to text
exit

preferable to be part of a Keyboard Maestro macro
anyone???