Comment links remain after deleting comments

While removing comments in the inspector, I noticed after typing additional text where the comment was in the Editor that it created a link as if the comment was still there, but without the color that’s assigned to the comment. The link doesn’t actually link to anything, and I can’t get the link to remove no matter what I do.

It doesn’t remove the link when I click Edit/Remove link. I also tried highlighting the text again, creating a new comment, deleting it, but the same thing happens. Lastly, I tried undoing to the point where the link was removed (after initially deleting the comment), but as soon as I type anything new in that text area or anywhere else), it creates the link again.

This has happened several times already, but it never happened before the newest Scrivener update for Catalina (3.1.4).

Thanks for the report, I can reproduce this easily enough in 3.1.4 (regardless of OS version), and it does appear to be a new problem.

It also looks like you can avoid it happening by ensuring that you move the cursor after deleting the comment. Does that work for you? I think the problem is that this is kind of normal behaviour actually, for example if you select some bold text and delete the text, then start typing without doing anything further, the newly typed text is bold. But it won’t be if you move the cursor. It temporarily holds the formatting attributes on the cursor until it is moved. So it’s probably something we were having to intentionally override the default behaviour for, to avoid footnotes/comments from reappearing like that.

Oh, and as for clearing the resistant formatting—try selecting it and a bit of the text around it, cutting, and then using Edit ▸ Paste and Match Style to nuke all formatting and paste as plain-text. Selecting from around the affected area should ensure that no latent hyperlink formatting is included “on the cursor”, as described.

The example with using bold text totally makes sense. I will also try your suggestion about stripping the formatting and will remember to move the cursor in future instances. Thanks for the help.

Note: I just opened my Scrivener project and the links aren’t there anymore. Go figure, lol!

That doesn’t surprise me! The way you described the stuck formatting sounded a lot like a RAM-only bug, or something that had broken silently in the software and was then causing secondary bugs that go away after a reload.

I have the same problem, and it persists even after closing and reopening a project. Having to copy paste text every time is quite cumbersome. Is there no update that can solve this, or make it go back to before, when it wasn’t happening?

I’m also having this problem, and it’s quite frustrating having to rewrite entire paragraphs because the comment link remains. Additionally, sometimes when I remove a comment, the link appears to disappear (great!) but then when I type in that position, the new text comes out as comment link text (that is, a different color and underlined) - I can’t quite figure out why.

I’m having this same issue, both with the comment hyperlink remaining even after I delete a comment from the inspector panel, as well as new text being typed around the comment still keeping the blue color and underline, even though it goes nowhere. Deleting the text that surrounds it and pasting it back in without formatting seems to be the only way to fix this. And, it persists from session to session after closing both the file and Scrivener itself. :astonished:

Is there a timeline to fix this issue? Thanks

Is there a fix for this yet? I have a lot of comments in my project and the cut, edit and paste style is time consuming.

Here is the release notes page, where you look up what has been fixed and when the latest release was posted. The short answer is no, the bug was documented after the last release.