Compilation and headings and formating


I’m having problems getting the headings for my index cards to appear after compilation AND keeping the formatting of the text in the file referenced by the index card after compilation. I can do one or the other but not both.

In the text I have a block quote that I wish to keep. Additionally I want to use the titles of the index cards as section headings in the compiled document. In the Compile options I set the Level 1+ text to include the title and as long as I do not compile that section As-Is then I see the title but I loose the block quote. If I select As-Is then the formatting looks good but I don’t have the index card title.

I’m trying to use Scrivener more but I need to understand when things should show up and when they shouldn’t.

Marcus Porterfield

Hi Marcus,

There are several of factors here:

  1. “Compile As-Is”: If this is ticked, the document is included exactly as it appears in the editor - the formatting stays the same and no title or other element is included.

  2. “Override text and notes formatting”: If this is ticked in the “Formatting” pane of the Compile settings, then the text and notes formatting in your documents (except for those marked “Compile As-Is” gets overridden with the formatting specified in the blue preview area. As this formatting will be applied to all of the text, then any block quotes will be adjusted to use the same formatting as everything else. If you want your text to appear in the same font as it does in the editor, you should just deselect this option (instead of ticking “Compile As-Is” for each document), and this will do the job.

  3. “Options”: You will see a little “Options” button next to “Override notes and text formatting”. If you click on that “Options” button, you will see that there are options there to limit the scope of the “Override text and notes formatting” setting. So, if you want a different font or font size, you could still have “Override text and notes formatting” ticked, but you could use these options to tell Scrivener not to change, say, the indents (so that your block quotes are still indented).

4). “Preserve Formatting”: This is available via the Format > Formatting menu. It’s an attribute that can be applied to text (the text gets a blue box around it when you apply this formatting). Any text with this attributed applied to it won’t be affected by “Override text and notes formatting”. So, another option is just to apply this to your block quotes.

5). “Quick Font Override”: This is another Compile setting. If you just want a different font applied to your text when you compile, you could use this instead of (or in conjunction with) “Override text and notes formatting”. This way you could just change the font face instead of other formatting.

From what you say, though, I think all you need to to is deselect “Compile As-Is” for these documents again and then deselect “Override text and notes formatting” in the “Formatting” pane of Compile.

In general, a good tip when compiling is, if you are seeing results you weren’t expecting, try selecting “Original” from “Format As” and start from there. “Original” will just set the compile settings to use the editor formatting and do nothing fancy at all, so it’s a good starting point. That is, it provides a sort of “vanilla” state, so it’s often easier to start from there rather than from one of the other compile settings that already have all sorts of formatting options set up.

Hope that helps!

All the best,

That tip alone is a help (wish I’d thought to ask in January). Have noted for the future.

Removing Override text and notes formatting did it! Thanks so much!