Compilation replacements actually substitutes in footnotes

Hi there,

In order to help a member of the facebook FR group, I tried to place a tag in multiples footnotes in order to place the same text in different footnotes.

Created 2 footnotes in which I wrote the tag <$olala>
in Compile settings, Replacements tab, I created a new line where <$olala> is replaced by some text (“c’est commun”).
Compiled the whole project
back in the Scrivener project, <$olala> has been replaced by the text “c’est commun”. If I change this text in the compile settings, Replacements tab, it’s not modified anymore.
if I keep Scrivener open, replace “c’est commun” by <$olala> back, it’s not replaced by the text defined in the Compile options when I compile again.
at this point, I don’t modify anything but I close Scrivener and reopen it, then Compile the project > the tag is replaced by the text I defined in the options.

I think it’s a bug, do you need screenshots, or is it clear ?
Thanks a lot !

Actually I tried for the first time to record my screen in a video in order to show you ; there it is !

Would it be possible to provide a small test project that has everything set up the way we would need to trigger this bug? I gave it a try by following your instructions, but I noticed that in the Replacement field (as well as the output), it looks like there are some strange characters in the replacement text that might be causing the bug. Without knowing what those characters are precisely, I’d have a hard time reproducing it.

Sure, I can send you my project, just tell me where =)

edit : just tried to put the tag also in the document, and it works like magic, so the bug seems to be located in the footnote.

Oh, just our main tech support channel is fine. Note the email addresses (the form doesn’t have an attachment function). Note down this thread URL, so that whoever gets it can flag me on it. As for creating the sample, use File ▸ Back Up ▸ Back Up To…, and make sure the zip compression option is enabled.

Much appreciated! This looks like a nasty bug—though thankfully it might be a little difficult to trigger.

It’s done ! Be brave, dear bugtrackers !

Thanks! I can easily see the problem now. The good news is that it is not permanent—I misunderstood you earlier in thinking the actual data was overwritten, but it looks to me as though the problem is cosmetic. If I close the project and reopen it, the footnotes go back to showing the placeholder. But with the ability to make it happen on demand, we should be able to figure it out why this is happening.

Ow, you’re right, I didn’t try to reopen the project when the tags are replaced.
Thanks for you quick answer !