Compilation without trailing dashes

Hello! How can I ensure that in the compilation process, in ePub Ebook (.epub) format, the text is justified and without hyphens at the end of the line. With hyphens the result is not good because it does not respect grammatical rules. Thank you!

You can turn off hyphenation in Scrivener, but I don’t know if e-Readers impose hyphenation if the text is justified. The problem with justified text with no hyphenation is that you can end up with huge unsightly spaces between words.

For that reason, I prefer unjustified, or to be pedantic, left-justified for anything other than print.

:slight_smile:
Mark

1 Like

It is a setting in the ereader itself.
Other than using the justification settings the device offers, I don’t think one can have any control over it.

There is a way to impose a split point for where it might be needed.
I don’t quite recall how, but I am really not sure it would be worth it, given how random the thing would be. I mean there are tons of ereaders, with different screen sizes, and user defined font sizes, etc etc…

The alternative is to publish in the PDF format and have everyone complain about the reading experience of your book.

1 Like
1 Like

Thank you all for your responses. In my case, when I compile in Scrivener in ePub format, when I open that file in Caliber or any e-book reader, the format is impeccable. There is not even a hyphen at the end of the line and it is justified, without space separation. However, when playing the file in Kindle Previewer, what I mentioned happens: the hyphens at the end of the line do not comply with grammatical rules, cutting the word wherever they want. I don’t know if it’s because the book is written in Spanish, even though the Kindle Previewer has this language selected, or what the reason is. It is a problem because I sell my e-books on Amazon and on Kindle they also have that problem. If anyone has had this happen and knows the solution, please tell me because I don’t know what to do. Thank you so much.

This is something Kindle/Amazon is doing. If Calibre and other ebook readers are correct, then Scrivener is putting the correct information in the file.

This happens when your language/Culture setting is wrong. With the correct language in metadata and body tags, hyphenation tends to be correct in all viewers and readers.

Calibre has a “Polish” command line tool that allows you to add Soft Hyphens in every word larger than one syllable. This works perfectly and won’t result in large word spaces when using long words together in one sentence using justified text.

1 Like

Resultado de traducción

Isn’t there something like that in Scrivener? Is this happening because Scrivener does not recognize that the language is Spanish? However, Caliber and other e-readers do not have this problem. Only with Kindle. I have asked Kindle and they answer that it is a formatting program and that it should send it in another format, but of course, in another format the format is not adjustable

Scrivener itself would not know how to recognise one language from another. Are you specifying ‘es’ as the language code in the Metadata compile option tab, where you would put your author name and so on? It’s toward the bottom. Without that it would indeed assume ‘en’ for English, and that could very well make a mess of hyphenation in an ebook reader that supports it.

2 Likes

Thank you so much! I changed the language code in the metadata, just as you told me, and it worked. A hug!

2 Likes