Compile adds double indents for each new paragraph

Hello,

I tried searching the forum for a similar post but couldn’t find one.

Whenever I compile to .doc or .odt and open the file in Word, the first line of every new paragraph is indented twice. The indent ruler is set for 0.5 and all the indents in my document are at 1. I know it’s a double indent because I can delete one without it going all the way to the left.

I have tried compiling with several templates including ebook and Standard Fiction Manuscript, with no luck. I’ve also gone in and modified the settings during compile for the text and text+ levels and removed indentions, but they are still doubled when I open the document up in Word.

Can anyone assist me in solving this?

Much appreciated!

Are you entering tabs at the start of every new paragraph as you type in Scrivener?

I wrote 300 pages of my story in Word before I discovered Scrivener so when I imported it it came with tabs. I have been using tabs since then.

I’m assuming since you asked that this might be the issue, but I thought Scrivener was able to set up the editor with different formatting than the compiling settings.

If that is the problem, is there an easy way to remove tabs for 400+ pages?

My guess is that Scrivener is treating the tabs as text that gets passed through rather than treated as paragraph formatting.

My sense is that the general concensus for most word processing/publishing apps now days is to avoid use of tabs for paragraph indentation and instead rely on paragraph formatting (ruler bar, template settings, etc.), so that things like indentation can be handled and adjusted without having to go back through and fiddle the actual text.

In Scrivener’s case, I believe that File > Compile > Formatting settings (select a level type, then click in the sample text in the lower window to see what the ruler settings are) will override the editor settings. As I mentioned earlier, I’m guessing that a tab just gets passed through the process as a character, rather than being treated as paragraph formatting. (Though something farther down the pipeline, such as Word when reviewing the compiled .doc, may choose to interpret the tab in some fashion.)

Following is one way to remove the tabs. There may be other/better ways.

You should be able to do an Edit > Find > Project Replace to get rid of the tabs… but some caution is in order, as such a change cannot be undone.

First, make sure you have current backup copies of the project. I go for paranoid… with at least a copy elsewhere on the same drive, and a copy off-machine on a USB thumb/flash drive, and a copy on DropBox… and quite possibly a copy burned to CD/DVD. And it’s not enough to just make backup copies… one needs to periodically test them and verify that they can be opened and are complete, regardless of what application one is employing.

Steps, after assuring backups exist, would be:

  • In Scrivener,
  • In one of the documents in the project,
    do a mouse or keyboard select of one of the tabs
    and copy it to the clipboard via Ctrl+C or Edit > Copy.
  • Edit > Find > Project Replace
    and click in the Replace: field and paste the tab
    into it via Ctrl+V or Edit > Paste
  • Optionally, you may want to limit the scope to just text
  • Click Replace.
  • Click Yes to confirm that you understand that the action
    cannot be undone and that you wish to proceed.
  • When the replace finishes, click Close.
  • Spot check several places in the project to verify
    that the tabs were removed.

A possible alternate approach (I didn’t test it) would be to use File > Compile > Replacements to replace tabs with nothing during the compile. They would remain present in the project, but not appear in the compiled output.

I could be wrong.

Hope that is of some assistance.

Thank you! I had tried find and replace in the past, but the copy/paste portion was just what I needed.

Now I’m indenting in the editor using the ruler only, and when I’m in word it ends up with only 1 indention.

Thanks again!