Compile Confusion

Hi. First time poster and technical halfwit here.
I’ve been writing a project on the novel template. I compiled the project before on a different machine and then continued writing. That machine then committed suicide and I transferred everything onto this machine from my backups (maybe not such a halfwit after all). The problem I’m having now is that I want to compile the, still unfinished, project and e-mail it to a friend but when I try to compile, all I’m getting in the compile window is the title page. The rest of the binder listing, the chapters, the folders, the character bios, everything else is missing including pre-compiled and new material. I’ve looked into each chapter’s meta data list and all have the ‘include in compile’ setting checked. I’ve also tried compiling with the ‘compile as-is’ option checked but they still won’t appear in the compile list. As far as I can tell, there is no difference in the title page settings from the settings for the rest of the project, yet that is the only option listed. I have another project on the go which I also transferred over from backups and was able to compile and send that one no problem. I should also point out that I haven’t used Scrivener for a couple of weeks and, when I opened it this morning, I installed an update. I don’t know if this might have something to do with it or if having already compiled part of the manuscript and then trying to compile again might be the problem. Either way, any help would be greatly appreciated.


If your entire book is not compiling, the first thing to check is the Contents compile option pane (you may need to click the blue arrow in the compile window to see that). This will show you a list of everything that is scheduled to be included. Do you see everything in there that should be there, or is just a title page? If it is just that, check your binder closely with an eye for how indented things are. Make sure all of your book material is indented below the draft folder (it may be renamed to “Manuscript” in your template).

That’s it, problem solved.
All I had to do was right click on each folder in the binder and move them one place to the right. Now everything is there in the compile list.
Thank you so much AmberV, you are a genuine star. :smiley:

Great, glad it is working! Just a tip for the future, you can drag and drop stuff around in the binder. So you could have selected all of the items and dragged them to the manuscript folder, dropped them on it and it would have indented them all at once. You can also use the same trick you did for multiple items simultaneously rather than one by one. The Move To command can work on many pieces at once.

I just wanted to add - I was having a similar problem and was about to post the same question when I noticed this. So thanks AmberV - you were also able to help me.