Compile does not work as expected for rtf files

Although I have selected the settings option to remove indents from first paragraph and after blank lines, when I compile my manuscript in rtf or docx format, all lines remain indented.

I know I could set these paragraphs the way I want them in the editor using styles, but this messes up my ebook formatting.

Any suggestion would be appreciated.

Just to cover this base: Did you adjust those things in the part of your compile settings specifically for the rtf/doc output targets?

Were the indents created in the first place using the paragraph indent setting, or with tab characters?

Yes, the settings were for sections, under the Times Manuscript template.

Indents were created using the paragraph indent setting. I never us tab characters for indent.

What tool are you using to inspect the output file? Word in particular can apply its own automatic formatting as soon as the file is opened, without necessarily telling you it’s done so.

Do you see the same issue if you compile to PDF?

I am using Pages to inspect the Word and RTF files, but I don’t think that is the problem. I have the same problem with PDF files.

Letting us look at the project will probably get this solved faster. Please open a support ticket, here:

You can email a project by using the File → Backup → Backup To command, and checking the box to create a ZIP backup.