Compile Feature Has Stopped Working

Hi … The Compile feature has suddenly stopped working.
I was able to compile about 1 weeks ago, but now, no.

When I click Compile, the button or from the menu: Nothing happens. No “Compile Box” appears.

I am an experienced Scrivener user … using the latest version of Scrivener 2.31, on a Mac OS 10.67

Thanks for any tips for solving this problem.


Very strange. Could you please take a look at the in /applications/utilities and let me know if there is anything pertaining to Scrivener there? If not, please choose “Reveal Support Folder in Finder” from the “Scrivener” menu and then attach the console.log file from the Logs folder? (Do this straight after trying to compile).

Hello and thank you …

Yes, there is a lot about Scriver in the file

I cannot cut and paste this information
but I did take a “screenshot”

How shall I send this information to you ?


Here is a screen shot of the file

That’s very strange. An error is getting thrown when you invoke Compile, but the error seems to be wrong. It is saying that a piece of code in Scrivener doesn’t respond to a particular message - but it does. I wonder if this could be as simple as a bad install - it may be that the Compile interface file is corrupted on your machine. Have you tried deleting Scrivener and reinstalling it yet?

Also strange is … just last week, the compile feature (using this version) worked perfectly.

No I have yet tried to delete Scrivener then re-install …
if that is the best option now, then I will wait 24 hours then re-install.

Keith, thank you very much for your fast replies.

Out of interest, why do you have to wait 24 hours? But yes, I would definitely try reinstalling, as my best guess is that this is a bad install. If that doesn’t help, let me know and we’ll take it from there.

All the best,

Out of interest … why wait 24 hours ?

After being a Scrivener user and fan for so many years
I have so much valuable information in Scrivener projects
I wanted to do the re-install when I have free time and a calm mind
and first back up all my Scrivener projects.

But probably I want to get things working sooner,
so I will try the re-install later today.

Problem solved by re-installing !

Compile now works.

Keith, thank you very much for your help.

~~ Zorba

Great! Glad you’re back up and running!
All the best,