Compile for MultiMarkdown Fails

What is causing compile for MMD to fail?
When I try to compile for MMD, I get error messages.
The data could not be written at the specified location
Error Parsing MultiMarkdown File
. . . Please check the standard error output below
2013-01-17 22:17:23.696 Scrivener[11039:203] *** NSTask: Task create for path ‘/Applications/Utilities/_WRITING/’ failed: 86, “Bad CPU type in executable”. Terminating temporary process.

I may be wrong, but this looks suspiciously like you are using a version of MMD that is not compatible with the PowerPC chip. Is there even a version of MMD that runs on non-Intel Macs? You ought to check, just in case. Come to think of it, I used to use a version of MMD on my PowerBook G4 a few years ago, so there must have been a version that worked on PPC at one time.


Edit: if that is the problem, try this download page, where there are some legacy versions for PPC, etc.: … downloads/

This article indicates MMD ships with Scrivener - … arkdown-3/

Previously, I only installed Scrivener 2.3.1 and MacTeX 2011, not MMD.
Per the article above, I installed MMD 3.0.1, but I still get the same error messages.

So, I downloaded — Alternate builds for older hardware or systems (e.g. 10.4, 10.5, PPC, i386)
But when I unzip, there’s no install package, only Unix executable files for ppc and i386.

How do I uninstall MMD?
I cannot find any MMD files on my hard drive; where should I look for them?

How do I install MMD ppc from Unix executable file?

It might be better to go to the horse’s mouth for info about MMD:

Perhaps you haven’t seen it yet, but there is a dedicated forum about Scrivener and MMD here:


I’m no expert – just another Scrivener customer trying to help you to find the information you might need. I don’t have all the answers to the questions you ask, I’m afraid.


Are the files in the Zip named like ‘mmd’ ‘mmd2all’ and so on? If so, just copy or move those into your /usr/local/bin folder. That is where Scrivener will be looking for an external installation, and use the PPC friendly versions instead.

I found the MMD files in Application Support, but don’t know how to install the legacy 3.2 version from the Unix file download.

Zip for MMD 3.0.1 opened to package installer. I ran it and the files appear to have installed at User>Library>Application Support>MultiMarkDown

Zip for MMD 3.2 download which is labelled legacy for PPC opens to a Unix file.
When I double click the Unix file it opens in Terminal, and says -
Last login: Fri Jan 18 08:41:00 on ttys000
/Volumes/Mr._MAC/Scrivener/MultiMarkdown/MultiMarkdown-Legacy-3.2/multimarkdown-ppc ; exit;
Macintosh:~ dstall$ /Volumes/Mr._MAC/Scrivener/MultiMarkdown/MultiMarkdown-Legacy-3.2/multimarkdown-ppc ; exit;

It doesn’t appear to be installing anything. I don’t know if I’m supposed to enter commands or what they should be???!

That’s just it running normally. If you double-click it without any data it won’t have anything to do. You have to run it from the command line and specify a file name to convert.

At any rate, it would be best to install the regular MMD distribution (it’s an installer). This will place the necessary files in “/usr/local/bin”. Now you’re going to want to go there after you run the installer, and replace the ‘multimarkdown’ program with the PPC version. So just use the Finder “Go” shortcut to get to the UNIX folder (Shift-Cmd-G, then paste in the path I provided), rename the file to ‘multimarkdown’ and drop it in, replacing the Intel one.

You do not need or want anything in your Application Support folder, most likely. The only reason to install the support package is if you want to mess with XSLT post production, or customise the workflow that Scrivener uses when you compile.

I don’t understand what you’re saying or what local/usr/bin is.
Is that a command you want me to run in Terminal or what?
Please direct as if instructing a child who knows nothing.
It’s easier and surer that way.

As stated before, I’ve already run the MMD installer for v. 3.0.1 and files are visible at User/Library/Application Support/Multi Markdown

I downloaded MMD 3.0.1 from here -

Zip opened to package install.
When that failed with Scrivener, I downloaded v. 3.2 because it’s labeled for PPC.
But when zip opens for 3.2, it’s nothing but a Unix file.

What am I supposed to do with that?
How do I install v. 3.2?

Well, first of all I would recommend using MMD 3.6, rather than 3.2, unless you have some specific reason to be using an older version. You need “MultiMarkdown-Mac” and “MultiMarkdown-Legacy”. Install the first one from the package. Then unzip the legacy archive, rename ‘mmd-ppc’ to ‘multimarkdown’, and then drag and drop it to your ‘/usr/bin/local/’ folder.

That is a path, a location on your computer. When you double-click on “Downloads” in your user folder, you are actually navigating to ‘/Users/yourname/Downloads’. That is the path. So ‘/usr/local/bin’ is a path to another spot. It is a ‘bin’ folder inside of a ‘local’ folder inside of a ‘usr’ folder. Again, the easiest way to get there is with Shift-Cmd-G in the Finder. Just type in that path. That is where the first MMD installer puts its files. You need to overwrite ‘multimarkdown’ with the PPC version you downloaded.

Thanks a lot AmberV.
I retitled the multimarkdown-ppc Unix file to multimarkdown so it would copy over the existing file.
After that I was able to use compile from Scrivener with MultiMarkdown, so I’ve upgraded to latest version of MMD, 3.6 as suggested.

Compile MMD-.html gives me something readable,
but why does compile -.rtf give me a file with black background and nothing readable, just a bit of dark blue, hardly legible gibberish scattered here and there?

Compile MMD -.tex gives me a .tex folder filled with .tex files, which I’m hoping I can learn to integrate with BibTeX via BibDesk.

Great! Glad it’s all working. You should now be okay even if you upgrade Scrivener. It will always use your installed version instead of its own.

Black background is a textutil bug. That’s a UNIX program provided on the system by Apple that MMD uses to create the RTF. You can just open it in TextEdit and set the background colour to white to fix it. But if you need a word processor document, I do recommend using .fodt instead of .rtf. You’ll need to load the .fodt in LibreOffice (an OpenOffice fork), but you can save it from there in a more suitable format (like RTF). The straight-to-RTF thing is really more for quick proofs of your own.

LaTeX: yes, basically you’ll want to create a folder for your TeX work and have the folder name end in “_mmd”. This way, you can continually compile into it and have Scrivener merely update the files it takes care of, rather than completely wiping everything out. That way you can move your .bib files any .sty files, illustration folders, etc. into the folder. The .tex files it creates (sans the main content file of course) will not be overwritten when you recompile. So you can customise these files if you wish.

I’m trying to learn MMD setup in Scrivener so I can integrate BibDesk cite keys, and have found this tutorial - … d-bibdesk/

But, I don’t understand the last part, “Make the PDF” -
…click “Set LaTeX” once, then click “Set BibTex” and click “Set LaTeX” twice more. Without any errors messages, you should now find eight more files next to your thesis.tex file…

I open Scrivener compiled .tex file in TeXShop (installed with MacTeX), but there is no button in TeXShop for “Set LaTeX” or “Set BibTeX”.

And after I changed the meta data settings in Scrivener as shown in the tutorial, I can export MMD - .tex, but can no longer export from MMD - PDF directly, and get the following error message -
The PDF file could not be created.
There was a problem generating the PDF file using pdflatex. Please ensure that you have any necessary supporting LaTeX files correctly in place, and that your meta-data is set up properly.

Is LaTeX installed as part of MacTeX? or do I need to install it for MMD - PDF compilation to continue working after I’ve changed meta data settings?

Is there a list/chart for compile/meta data settings indicating what each setting does?
I’ve looked in help manual and online but don’t find any.

I could also use a list/chart for compile/formatting settings indicating what each setting does.

I’m not super familiar with using BibDesk and LaTeX, you may wish to contact the author of that article if you don’t follow what he is saying.

Yes, that is what MacTeX is. The reason PDF doesn’t work is probably down to some other problem introduced by the tutorial. Again I’d see what the author intends. I had a look at his meta-data block and I’m not sure what he’s going for with it. There doesn’t appear to be a LaTeX preamble specified.