Compile for Print Not Respecting Block Quote Right Indent


I am having difficulty with my first publication in Scrivener. Using almost the default Block Quote formatting preset (save for some font face changes), I cannot get the program to show a right indent on compiling for print. As this is for an academic work on patristics, that right indent is absolutely necessary.

Now, I understand I could probably make it work if I export to Word and search/replace the style, but I would prefer to do everything in Scrivener so I can also export an eBook of the same publication with the right indent respected.

As of now, I have used the Format > Text > Indent > Increase Right Indent command, but to no avail. I have also manually set the right indent using the ruler, which shows the proper indentation in the editor, but not when compiled.

Any ideas?

Thank you.

There are several things that could be going on here:

  1. Your compile settings are overriding formatting and dropping indent settings
  2. In conjunction with the above, your block quotes are not Preserve Formatting protected (blue box around them)
  3. The right indent is set off the page/text-block and so isn’t working as expected. When you open the RTF in a word processor, does the right indent flow off of the page?

Do any of these look like the culprit? If #1 or #2 is the problem, you could perhaps get around it by setting “Preserve tabs and indents” in the Options panel, found in the Formatting compile pane. The main drawback to that is that if you didn’t write with indents in the editor, and are using the compile formatting override to fix up the paragraphs nicely, that option will negate it.