Compile = Formatting Disaster [BUG LOGGED]

I searched the forums and couldn’t find any similar issues, so here we go:

I’ve been using Scrivener Beta 1.3 for about a week now to work on my NaNo and I am definitely in love. Today, out of sheer curiosity, I decided to check out the Compile feature to see how my compiled text would look if I opened it up back in Microsoft Word 2007.

The answer was… scary.

I chose to compile to an .rtf file, using Novel Standard Manuscript Format.

First of all, Word froze while trying to open the file, until finally popping up with the following error message:


My document is only 29K words and assuredly NOT 10k-plus PAGES.

Second, once I exited the error message window, the text within word looked like this (my last name is blurred for privacy reasons):


The text of my title page is ranged down the lefthand side of the page, ad-nauseum, for what Word believes to be 10,000 pages. Now, if I use the scroll bar to scroll down, I can actually see my text… whereupon I noticed that all of my italicized text had been converted to underline, and my double-spaces at the end of sentences look to have doubled again. Also, as soon as I release the mouse button on the scroll bar, it snaps back to the first view. In other words, my text is present in theory, but not in a way that can be edited.

Finally, I decided to check out the file in Word Pad to see if perhaps Word 2007 was the problem. Behold:


An ill-formatted version of roughly half the information on my title page (personal info again blurred for the sake of privacy). And that’s it. No further text, not even everything that was on the title page.

Before submitting this post, I decided to try a second Compile, using the Custom format, to see if it made a difference. The result in Word Pad was the same. Microsoft Word is still frozen, but looks to be having similar difficulties.

Has anyone else noticed similar difficulties with the Compile feature?


This part is not a bug. Standard Manuscript Format ™ uses underlines rather than italics, as that’s what many publishers want. Change the compile options to make this go away.

The rest … yes, that sounds pretty horrible.


Are your your margins set way too thin? Check the formatting pane in the compiler and see if perhaps you move the right indent slider all the way over to the left side.

I have this same problem when trying to compile into Word. I am using the Windows Vista OS. Does that make a difference?


Don’t worry we’ll fix this. It is a know bug and will be addressed.

I just submitted a ‘bug’ report on a similar issue, though I was trying to use Open Office Writer. It did not lock up the OO Writer, though I got exactly 22 pages of nothing. Nary a word to be seen. However, I was able to open the resulting .rtf file using RoughDraft. Mangled, but all words were safe and sound. :smiley: It was interesting reading your comments.