Compile formatting issue

I’m setting up the skeletal infrastructure for two books within one project, using the Novel In Parts template, and filling them with dummy chapters and scenes. I tried compiling in Default mode and both Manuscript ones, Courier & Times. But the last of the three, Times, has revealed a problem. I don’t know if it’s me or a bug.

Default and Courier work like a dream, but Times will not indent the first line of any new scene/document - it goes straight out to the left margin, no matter what I do. After that initial paragraph, everything then indents as expected. It’s just the opening sentence that’s the problem, and it happens every single time.

Twice I made a fresh template, cloned from an entirely new project, and then typed in all new text, so the issue is not a holdover from copy-paste formatting. And I never went near the manual tab key. Anyway, I don’t see how it can be a template fault when two of those three Compile modes are fine.

I’ve been compiling for both PDF and RTF - I don’t have Word, and my ODT programme is ancient (yes… I know…). I’ve got a MacBook running Monterey 12.7.4, the highest OS that Apple will allow to my 2016 Retina-build machine. So I can’t update my computer beyond that.

How do I fix this? TNR font is absolutely essential these days.
Too many agents (including the one I have my eye on) refuse to accept any submission that uses something else.


Which is the standard, so the other two templates are not following standards.

First lines after headings, other elements like images and lists, and empty lines start flush left. Paragraphs following other paragraphs are indented to make finding the start of the next paragraph easier for readers.

Hope this helps

1 Like

I’ve got a question for you - I’m running into the opposite problem when testing compile options. This was for RTF from a novel with parts template.

I’m getting all paragraphs flush left even when I tick any of the options for no indent after elements, blank lines etc.

Any clues on this one?

Win11/ > Libre (no MS Office installed)

A compile Style interfering or overruling that setting?

That’s what can’t figure out.

In particular, I’m having this problem with ALL sections that have more than one paragraph including run-in heading+text, and heading +text.

I have been unable to make my “sample” views show a flush left first paragraph only, with the subsequent paragraphs indented. (File>compile>styles) or compile>assign section types/edit styles - I am using copies of compile templates)

The sample jibberish ends up all one way or the other. I know I’ve got to be missing something simple. I never had a problem compiling in 1.9, I’ve read through what’s new and the manual. I’m at a loss.

I’ve adjusted settings on my ruler, tried indented paragraph styles with ‘flush left first’ ticked. Multiple test projects/styles/no styles, override, don’t override… Hundreds of combos over days.

The only way that has worked consistently is if I break out all first paragraphs, and I know that this shouldn’t be necessary.

Where should I look, and what is the order of preference - ie “which formatting where” takes precedence over the other?

(Win11/3.1.51, Novel with parts, compile to rtf or odt, non-fiction with parts. I do use custom styles in the editor that have unusual indent and tab settings that correspond to styles in Libre and the style sheets from the publishers. )

Examples of custom indents/tabs:

Children style(starts flush left)
“+” (left tab) #n (decimal tab) #r. (set indent) “text”

Grandchildren style (indented under the above)
(decimal tab) #n. (Set indent) “Text”

Subsequent lines are lined up under “text”, and additional paragraphs (infrequent) should be indented under those.

My sample jibberish doesn’t show any of this formatting, (it only shows the ruler markings when I highlight the jibberish.) I tried to use prefixes for everything before “text” in compile, but I need to see these details in the editor to cross-reference, so having it only set in compile doesn’t work.

In the Compile Format Editor, check the Settings tab for the Section Layout you’re using. See Section 24.2.9 in the (Mac) Scrivener manual for more information.