Compile Function - no titles, incorrect font

I am having the same trouble with the Compile function that jenniferso and maribel noted. I’ve read through all the posts related to their issues, following the directions and I’m still not having success. When I compile my manuscript, it comes down as Optima, despite having selection Times New Roman. In addition, there are no chapter titles. The chapters titles used to print automatically, I seem to remember.

I’m sure it’s a matter of something I’ve clicked or haven’t clicked that I should have. For the most part, the new version is awesome but the new compile function feels overly complicated and not as user-friendly as the rest of the software.

Where do you keep your chapter titles, in the documents themselves or as the document titles? Are they in separate folders, with the actual writing in subdocuments? Have you specifically reset the font for the folder, doc group, and single doc “Level 1+” types in compile? (If you read through the the other thread, you’ll note that there may be a recently cropped-up issue with the TimesNewRoman pre-made compile setting resulting in Optima font instead of Times New Roman, so that could be the issue.) Do you have “compile as-is” selected for any of the documents?

If you could perhaps post a screenshot of your binder and of your compile “contents” and “formatting” selections, that might help. You can use cmd-shift-4 to select an area and take a screenshot (it’ll become a .png on your desktop and you can then upload it to the forum).

Okay, based on these images, it looks like you have only a level 1 folder (“Chapters”) and then a set of level 2 single documents. Are the titles of those documents (e.g. “Ghost Story - revised 12/2”) the titles that you’re trying to include? If so, you need to make sure that in the formatting pane you have not only the text box selected but also the title box for the document Level 2+ (the last one on your list). The other settings in that formatting pane for all the level 1+ types aren’t getting applied because you don’t have anything at level one except the Chapters folder, and you don’t have that marked for inclusion according to the contents pane.

To adjust the font, check “override text and notes formatting” in the formatting pane (at the top, above the document types). Then select the level 2+ row of the formatting pane, place your cursor in the body text of the sample text and format it to appear how you want your writing to look–set the font with the italicized A button furthest to the left in the format bar, adjust the indents, etc. Place the cursor in the “Title” line of the example box (it should appear once you have “title” checked in the list) to format that separately.

Does that get what you’re looking for?

Just a small contribution, but given the comments about compile problems with Times New Roman, you could set the output to Times instead. It is very similar, to me the only real point of note being slightly different — and better in my opinion, cleaner and better kerning etc. — font metrics. If you send a file in Times to a Windows user who opens it in Word, in my experience that should automatically replace the Times with TNR, so they won’t know the difference, though page-breaks may change.


I think the issue with TNR is that the preset compile for “Times 12 pt with Bold Folder Titles” is for some reason coming up with a different font…not the slightest idea why…But I was able to create my own modified version setting the font to TNR and saving that, and that’s remained TNR properly after quitting and reopening Scrivener, etc. So I don’t think it’s that the font itself isn’t sticking for some odd reason, just that the compile setting got modified somehow?

Yes, a bug appeared in that preset at the last moment so that it uses Optima instead of Times New Roman - this will be fixed for 2.0.3.