Compile ignores my selection

I wanted to compile just one chapter. So I opened the Compile window, chose Word format and went about selecting the parts I wanted to include in compile. To be sure, I deselected all the parts and then selected just those I wanted in compile. To no avail: compile still outputs the entire manuscript, including the ToC. If I close the compile window and then reopen it, I see my selection still appearing correctly, but compile simply ignores my choices.

I am not sure by what actual mechanism in the software you refer to as “selecting the parts”, as there are a few different ways of doing so—each with their own particular advantages.

You might find this post, along with the thread discussion itself, to be helpful as it goes into detail on some of these methods. There I discuss my preferred method for quickly compiling “one-off” selections.

But that aside, it would help to know more precisely what you are doing, so that the underlying problem can perhaps be understood. A good way of doing that is with a copy of the tutorial, in the Help menu, so that we’re all using the same material and settings. Then, by documenting each step you take with as much detail as possible, show how to achieve the effect you suspect is a bug.

Hello Amber,

thanks for your help. I may have overlooked the instructions for compiling, but the screen options looked to me, probably wrongly, as self-explanatory.

I enclose a screenshot with which I hope to further explain the nature of my problem. In this first screenshot you see the options I chose, hoping to be able to compile just
these parts. These options selected, after pressing Compile, I was trusting to see my output file containing nothing but these parts.

My favourite choice would have been to be able to export my files just like this:

However, this option, much as I have looked for it, doesn’t seem to be available.

I hope this explains what I was hoping to achieve and I will give a look to what you recommend as first option for compiling the way I want. However it’s not entirely clear to me, where the Contents List you mention is to be found. If I search for Contents List in the Help Menu, it returns nothing. I surmise you might be intending the Outliner mode, but if I switch to this mode, this is the screenshot I get, where there is no mention of Contents List.

I appreciate that Scrivener is incredibly powerful, but sometimes some important functions are not easy to identify.
Looking forward to hearing from you, kind regards,

Piero

All right, so one thing to be aware of is that filter icon (the funnel looking thing) to the right of where you select the main compile source group, at the top of the list. This will, as you might guess, filter the results based on more complex criteria. You can tell when a filter is active by its highlighted appearance (it will just be normal grey when inactive).

Click on that, and ensure you haven’t changed it to Compile: All. For this way of working, you probably want Compile: Included Documents only. You should note that when doing so the filter icon turns grey, from purple, as that is the default setting.

And yes, there are a lot of options for filtering the draft. This allows for a considerable breadth of flexibility in how content can be selected for output. You can easily print certain chapters, or selections based on proofing status, output individual books from a series, or even produce different editions of the same text, where some binder items are excluded based on some flag you set.

One thing worth noting with the screenshot below: the Windows version collapses folders into a hierarchical menu system in that dropdown, so it’s a lot easier to find the Current Selection setting. On the Mac the whole draft is printed in an indented fashion into the menu. Simply hit the End key while looking at the Contents dropdown to skip to the bottom.

Honestly I think this is one area where the Win version works better, as some of these really useful options are utterly buried on the Mac, in outlines longer than a screen-height. Plus, in most cases if you just want to print Chapter 32, you don’t want to have to scroll through several miles of subsubsubsections to find it.

image

Thanks. However these options have a different layout in my Mac version

Here’s how it looks on my Mac (Scrivener Version 3.2.3), which to me is the same features as in @Vincent_Vincent’s screen shot. Perhaps I’m missing something.

Although at this point… “One thing worth noting with the screenshot above…”