Compile issue - carriage returns missing after compile

So I was trying to export my WIP to my kindle because it’s been a few months since I’ve really looked at it and suddenly single carriage returns at the end of a paragraph are not rendering correctly. In the output (doesn’t matter if it’s a preset format or one that I’ve edited the result is the same. I’ve attached a screen shot showing the output in Word and the source Scrivener file on the right.

Surely I’m just missing a checkbox somewhere, right?

What I see from your screenshot is that your text in word is 1) justified, and 2) doesn’t have any first line indent.

Make sure everything is set ok in your compile format / section layout :

You might actually not want to override it ; unlike in my screenshot.

Or “styles” tab, if you used any.
. . . . . . . . . . . . . . . . .

As for the paragraphs being all merged into a big long one, could be that for some reason, in the replacements of either the compile format or the compile panel itself (most likely the compile panel, since you say you tried different compile format with the same result), you happen to replace carriage returns with nothing.


In any other case, you could try compiling to PDF, and if all is fine, then you’ll know that it is probably an issue with Word, not Scrivener.

Using unmodified compile formats yields the same result. (at least it’s consistent…) It’s happening on every compile format, regardless of output format.

As far as I know, the only stuff that affects compile is the settings in the compile dialog, correct? This is just baffling to me and I’m beating my head against my desk trying to figure it out

(Edit: I just opened two other projects and they compile like they should into any format I want. Is there a way to reset all of the compile formats back to the template defaults, short of creating a new template and importing the contents of the existing project?)

What about the replacements ?

Replacements didn’t change anything.

This is an issue specific to this project though. Other projects are fine.

This is using the built in formats, not ones I’ve modified that are project level only

Then I suppose the best thing to do would be to create a blank new project, and drag/drop everything in it.
Perhaps start with only a few documents, and test compiling first.

So a new project compiled fine. I have moved everything into the new project. I’m still curious as to what happened to the original project…

Gremlins, probably.
Some funky line of code throwing the thing off ?
Devil worshippers ?
Anti-carriage-return extremists ?

1 Like

I think it’s the Anti-carriage-return extremists…