Compile Issues in 1.73 (and earlier)

It’s been about 10 months since I needed to compile. I ran into some errors using 1.71, so I updated to 1.73, but the same problems persisted.

The specific issues are as follows:

The docx compile produces a file Word claims is corrupt and will not open.
The doc compile produces a file that gives part of the first chapter a 7.12" indent, drops formatting like italics throughout the document, ignores the “page before” instruction, and ignores header and footer locations.
The rtf compile just has the first chapter indent glitch. Looking at an early draft compile I sent to my cover designer, it has the same glitch.
The pdf compile produces a gigantic image file that I have to manually convert to text in Acrobat.
The epub conversion seems to be normal (which is good, since that’s the format I normally use to submit ebooks).

I read in another thread about Bit Defender flagging the Word converters, which it did on my machine, but I told it to allow. Then I checked, and the Word converter is on its exclusion list.

I notice that the Word converter progress bar is showing 4% when it declares the conversion finished.

Even if the Word converter is still being attacked by Bit Defender, should that affect the other converters?

First off, it definitely sounds like Scrivener isn’t using the Microsoft Office converters at all. These should be available for DOC, DOCX and PDF if you have MS Office 2007-2013 installed, so if you’ve dealt with the BitDefender issue, try setting them up in Scrivener. In Tools > Options, click the Import/Export tab, then click “Export Converters…” and choose the DOC format from the left drop-down menu and “Microsoft Office” from the right. Repeat for DOCX and PDF, then click OK a couple times to close out of options and try compiling to one of those formats. Does that work for you?

If the Office converters aren’t working, I’d try setting DOC to “RTF-based” instead of Doc2Any, which I’m guessing is what it’s using now. The D2A converter doesn’t support a lot of features, such as the page breaks, so it’s really only the best option when you don’t have MS Office available and your word processor won’t read RTF files, such as happens with a few iOS and Android apps. In that case you may want to compile to DOC using the Doc2Any converter so you can do some editing on your mobile device and then copy the changes to Scrivener later. For you, the RTF-based option will be much better; Word will open it without issue, and it will retain all the features that a regular RTF compile does.

For DOCX, if the Microsoft converters aren’t available, “Scrivener” is the only option, and for heavily formatted files especially that can sometimes produce the “corrupted” message when opening in Word. Usually you can click through it enough to have Word open the file anyway (maybe “repairing” it as part of the process)–it’s not generally an issue with the any of the text in the file, but that some flag in the file format written by the converter isn’t rendered a way Word expects. Once you have it open in Word, you can re-save it, so you should avoid any of the “corrupted” messages in future. That said, there’s really no reason not to just compile to RTF or the RTF-based DOC file and then resave it in Word to the DOCX format, since RTF will be less lossy. (It may not matter, of course, but for instance if you’ve used Scrivener links in your project, they’ll compile as internal links using RTF but are not supported using the “Scrivener” converter for DOCX and will be removed.)

I can’t really say what’s going on with the PDF file that it’s creating an image rather than text; that isn’t something I’ve seen before with either converter. I’d try the Microsoft Office converter for PDF if it’s an option, and otherwise you may be best compiling to RTF and then saving to PDF from Word. If it’s possible to share a sample project that demonstrates this issue when compiled to PDF, though, I’d like to take a look.

As far as the indent, that seems more like a formatting issue somewhere in the project rather than a converter problem. If you are overriding the formatting during compile, take a look at the Formatting section there to see how the indents are set for main text in the row for the document type and level that first chapter is (especially likely if it is different from the other chapters). If you’re not overriding formatting, check the file directly in the editor and make sure the indents are as expected (you can toggle the ruler from the Format menu). It could be you’ve set “Compile as-is” for that first chapter and so it’s compiling differently from the others.

Thanks for the quick reply!

I don’t have access to my desktop right now, but I guess it must be using doc2any conververts, just as you suggest. How that happened I don’t know, since I’ve never changed the settings in that area. Interestingly, even on this laptop, which is set to microsoft office converters, Bit Defender still finds the doc2any converters to object to, even when they are not the ones being used.

The weird indent on part of the first chapter seems to have stemmed from some kind of file corruption. The chapter was not formatted any differently from any of the others, and there was no sign of an extra indent, which didn’t show up in a scrivener pdf or epub conversion, but did show up in doc, docs, ms office pdf, and rtf. How’s that for a weirdly specific problem? Nonetheless, I realized that chapter had to be the problem, because I tried old projects and the current one with the first chapter excluded, and the extra indent was not present. In case anyone else has this odd issue, I solved it by copying the chapter to Word Pad (oddly the copied text did not preserve the weird format in either Word Pad or Word), then saving as an rtf in Word Pad, re-opening the file, copying and pasting the contents of the new file into a new chapter 1, then deleting the old chapter 1. Presto! No more problem. I can now export to rtf, doc and docx flawlessly once again.

The only thing I haven’t solved is the PDF issue. The converter still stubbornly saves to an image type PDF. The only difference between the two converters is that ms office produces a 50 mb image file, while scrivener pdf produces a 500 mb file. That’s not a problem for me, since I never use Scrivener to generate PDFs anyway; I did that now only because I was experimenting with my earlier conversion issues. I’m guessing most people probably don’t use it PDFs, which may be why the issue hasn’t surfaced before.

The Microsoft Office conversion is done by the Doc2Any tool accessing Word’s libraries, so BitDefender blocking Doc2Any will prevent the Microsoft Office conversion.

I can’t say what might have happened with the indent in the one file. If the problem was just the first-line indent, perhaps a stray tab, which was set differently in the compile formatting than the editor? I think most ebook readers ignore tabs, so that could explain why it was only present in some compiled files and not others. In any case, I’m glad you’ve got it all working now.

As far as the PDFs, I still am not sure what you’re seeing. Plenty users do create PDFs from Scrivener, and I’ve done it myself without getting an image file, so I wonder if it’s something particular to the project. If you have a chance to send a sample project that compiles this way and could post it here or email it to AT literatureandlatte DOT com, we’ll certainly take a look to try to figure out what’s going on.