Has anybody had a problem with compile not working. I want to shoot myself.
I’m running Mac OS OX, Scrivener 2.7.
Tried compile synopsis titles hangs up on ‘converting files’
Tried compiling whole document, no luck.
Will compile to print but not to save.
MS. Word, latest version.

Since you mention “Converting files” is where the hang happens, I presume that means you are using one of the word processor formats other than RTF, does the software compile with RTF or any of the other settings for that matter other than DOC/DOCX/ODT?

If so, your Java installation might be damaged, it’s hard to say without more testing, but one thing you can do is disable a checkbox in the Import/Export preference pane at the very bottom, Use system version of Java for conversion if installed. With that disabled, an internal and minimal version of Java will be used instead of whatever is installed on your Mac.

If that works, you might want to look into repairing your Mac’s Java installation, especially if you use programs like LibreOffice or Kindle Previewer.