Compile "Original" Preset issues

I was under the impression the compile “original” preset compiled the writing exactly how it looks in Scriviner. When exporting to a to PDF the spacing is slightly altered. This might not be a big deal for novel writers where the writing is just a wall of text but it’s very annoying for my script format. I have it set up in Scrivener so the description of the Screens and Swipes are together. In the attached image the left column is how the script looks in Scrivener and the right column is the compiled as PDF document. You can see how on the compiled side the dialog runs onto the following page.

I have messed around with the various separators in the compiling menu but each option doesn’t replicate what is seen in Scrivener leaving me in the same problem. Having to guess how I should format the script to get what I want out of the compile kind of defeats the purpose of compile “original”

If their’s something I’m doing wrong in the compiling process please let me know. I would greatly appreciate it. If not I would greatly appreciate it if the future updates of Scrivener would solve this issue.

Thanks for your time.

“Original” compiles the text formatted exactly as it appears in the editor, yes. This says nothing of page breaks and such, though, as this depends on where your page breaks fall and separators and suchlike, because “Original” makes some basic assumptions about how most users will want text arranged, which do not apply in your case. “Original” does this:

  • Compiles the text exactly as it is formatted in the editor.
  • Places a blank line between each text document.
  • Places a page break before any folders.

You do not want the second one of these if you want to get an exact match between the editor and the output, and you want to get rid of the separator padding in scrivenings mode.

To format things exactly, this is what you will need to change:

  1. In the Preferences, under “Formatting”, tick “Separate scrivenings with single line breaks”. This will get rid of the extra spacing between documents in scrivenings mode in the editor, which is there to give the horizontal line divider some breathing room and is not intended to reflect the output. Changing to single line breaks will turn on a more subtle divider and run one document into the next with only a single return character between them.

  2. In the “Separators” pane of Compile, change the text separator from “Empty line” to “Single return”.

That should get things as close between the editor and output as possible.

All the best,

Thanks for the response Keith. The advice really helped out.