Compile Place Carets on Title / Author Name

When I compile, everything looks more or less okay. However, I get carets (or whatever they’re called) around my book title and author name. Is this correct?
by <$MY NAME>

Well, I think we would have to say that it is not “correct” if you don’t want carets around your title and name!

P.S. Do you mean by your post to say your compiled output looks something like:

<The Saturnian Gambit>
by <O. Lonoff>

What’s the “$” for, there in your post ?
Are you somewhat referring to placeholders?

Yes, except I am getting the dollar signs as well. So I’m getting something like:

<$The Saturnian Gambit>
<$by O. Lonoff>
I think either my Front Matter folder contents or my compile file is either corrupted or messed up in some other way. Wondering whether I can change out that content for different files from a newly created project.

(I see no reason yet to think your project is “corrupted”.)

This looks to me like the result of a misunderstanding of placeholder text – of mistakenly typing info into the body of some legit placeholder string. Is there somewhere in your Front Matter docs that those strings of text literally appear? Then that is your culprit. You typed them in there.

Here are two legit placeholder strings:


which (if left alone!) would, upon compile, be automatically replaced by your project title and author name (as these are specified in the metadata pane in the Compile dialogue box). BUT if you saw those and, for example, literally replace ‘author’ in the above with your name you would have something that no longer functioned as placeholder text and so would output just as is – angle-brackets and dollar-signs and all. That is one way to achieve your funny result.

Speaking of the metadata pane on the Compile dialog sheet, another way to get your funny result would be if that pane had the text you are seeing literally typed into it.

For more on placeholder text, see the Help > List of All Placeholders, or check out the Scriv manual on that.


Whoops. I guess I did! I’ll fix that.

Strangely, I embedded the recommended legit placeholder strings
in the appropriate place, and also checked the compile dialogue and I still have the same result. Obviously compile is doing something weird, or I am.

Not sure what’s going on. I created a new project with new Front Matter file, transferred my novel into it and am getting the same result, carets around ProjectTitle and Author. Is it picking up something from preferences?

I reset Preferences by restoring to Default settings, then compiled, and it restored to proper behavior.

1 Like