Compile problems with front matter

In my original MacOS document, I have different front matters that contains a cover and text sections (titles, copyright page).

When I open this doc and compile on the latest Windows beta, I have the following issues with my front matter section:

  • The title page (a .jpg book cover) isn’t compiled. It is compiled fine in the Mac version. The cover shows up in the binder on Windows, so it’s a compile issue.
  • My copyright page appears entirely in italic. It is assigned the same layout as most of the sections in the rest of the book (section/new page) but it is compiled all in italics, with the wrong font size (larger). This doesn’t happen in the mac version, or in the other sections of the book. There are some italics segments in the page (including the first line) but not only italics. The copyright page looks fine in the editor, so it’s a compile issue.
  • My title page uses the font Special Elite and the layout fancy title (as is). When compiled, the subtitle formatted with Special Elite comes out compressed (narrower gap between the characters) and in bold. No issue in the editor or on the mac version (or in the other elements of that page, except that the whole page has a larger top margin than on the mac.

As these compile issues have still not been fixed in beta 19 or beta 20, I’m posting some screenshots showing the spacing issue with Special Elite and the missing .jpg (book cover) in the front matter. I still have the issue with the unwanted centered italics in the copyright page, but I can’t reproduce this with a fresh test file.

Here is the way the title page with the Special Elite font appears in Mac OS:

Here is how it appears in Windows (compile section is “as is”):

Regarding the missing book cover, I’ve added a screenshot of a title page sample in the front matter. when I ask for the front matter to be added, the title page appears in the compiled PDF on Mac OS:

In the PDF generated with Windows, the .png is not present, despite the fact that the file is present in the front matter folder included during compile.

I have made a ZIP file with a test project that should help reproduce all the issues I have reported that are still not corrected. Please let me know if you’d like me to send it to support, and how. This zip file includes the PDFs generated to see the differences in compile results.

I’m using a variation of the Paperback 6"x9" compile format, I’m happy to add it to the ZIP if you remind me where it’s located.

HI Manni,

Please send the zipped test project to with a link to this thread and attention it to Bryan.


You’re welcome, done, and thanks! :slight_smile:

Did you have any luck reproducing this one?

This isn’t fixed in beta 21 / RC1.

I still have all these issues in beta 22 / RC2.

This isn’t fixed in beta 23:

  • The cover is still not compiled in a PDF (it is in an EPBU or MOBI)
  • The Special Elite font is still too narrow (compile only).

However, the text in italics on my copyright page seems to be fixed.

Hi Bryan,

This has still not been filed, is it because you can’t reproduce or because you believe it’s not a bug?


Hi Manni,

Neither. I have reproduced the problem and am working on finding the cause for your font issue. It appears that creating a new document with the font does not reproduce the issue, but the copying the document does. In looking at the file itself there appears to be a second font attached : {\f2\fmodern\fcharset0\fprq2 Palatino-Roman;}} I am working on looking into it but as it concerns only this instance and can be gotten around by creating a new document it is not at the top of the list at this time.

As for the cover issue, it looks like cover images for pdfs was a more recent addition to the Mac program that was not present when it launched. I am unable to say whether or not that ability will be added to the Windows version before or after launch.

Hi Bryan,

Thanks for this reply, much appreciated. :slight_smile:

Noted for the lack of cover being a non-implemented feature.

Regarding the font error workaround, by “creating a new document”, do you mean the whole document, or just the part(s) (files/folders) where the font is being used?

Because if it’s the whole document, it’s not really an option when you have a 160,000 words manuscript existing in Mac and you plan / hope to be able one day to edit / compile in both / either platform(s)…

Document refers to the single item in the binder, as opposed to Folders.

Great thanks.

Hi Bryan,

Just to say that I have tried your workaround for the special elite issue, and at least here it doesn’t work (this was using beta 30).

I created a new section (text) in my test document, and formatted some new text with Special Elite. It looked fine in the editor, but still had the wrong spacing when compiled.

I even tried to create a brand new test document, using the fiction template, and a standard compile format (I used paperback 6"x9") and the output was still incorrect.

For your information, the test page uses the “as is” format, in case it makes a difference.

So please could you log this bug and bump this up, as it’s not an issue that can be solved with your workaround.


Does this behavior change when you enable Print and PDF Hinting? (file> Options> Editing> Options> several lines down, right side of the page) When I set this to default, everything’s fine, but on my machine, default has some form of hinting. If I turn hinting to “No Hinting” I see the behavior you’re seeing.

Thanks. Both hinting options are set to default (another user suggested I check this in a different thread). Also I only have this issue with Special Elite, not with any other font.

Sounds like the font may have some special characteristics to it.

If you change the Hinting to “Full Hinting” (for Print and PDF), does the behavior change? I’m not sure of the algorithm Scrivener uses to choose its default, but it may set it differently for different computers.