Compile problems with "Novel with parts" template

Hi there, and welcome to my first post.

I try and re-try and re-try Scrivener again and again, go off it as soon as I have tried to compile, copy+pasted every little bit into some other novel writing software and then return to Scrivener for the next bash, hoping things work out finally … and again the compiling throws me out.

Here’s the story, I hope someone can shed some light on this.
I use the template “novel with parts”, which is generally the kind of stuff I write. I write in German, so I re-name the folders in the binder, then happily outlining away, then even more happily writing some scenes, creating the title pages, bashing away … and the do a test-compile to .rtf format, and it goes so pear shaped that I go off Scrivener completely for weeks on end!

It does not look ANYTHING like it should according to the sample manuscript! The title page for example say CHAPTER ONE, under which it says title page, under which name and address and word count come in that hideous table format as is on the editor, THEN the name of the novel and author.
So then we have a page break, and then it says CHAPTER TWO, after which my prologue kicks in. At the end of the prologue there is another page break (fine), after which it then says CHAPTER THREE, and then as I put in “Teil 1” (which is “Part 1”), the page break as I put it in at that point, and then CHAPTER FOUR, after which my own “Kapitel 1” (as in “Chapter 1”) begins.

So basically before EVERY SINGLE page break Scrivener happily puts in a new Chapter start which I do not want to be there! Which I did not put there and have no idea how to get rid off!

Having to go through an entire novel when finished writing and compiling it to remove these annoying “CHAPTER WHATEVERNUMBERS” sort of defeats the purpose, doesn’t it?

I was so annoyed earlier, after writing three scenes, compiling and noticing the same old problem, that I kind of kicked the entire outline in the bucket without having saved it first (luckily I do have the scenes I wrote, as I had - irony! - just compiled them).

Is this a known bug? Is there any way to work around this? Where can I remove these CHAPTERTHINGIES for good, not only do I not need them, but they actually turn up where they should not (I mean c’mon, BEFORE even the title page???)

I generally like the way Scrivener works, what with corkboard outliner and well defined organizing your work, which is so useful when writing something which consists of more than 10 pages. But these compile problems sort of take the fun out of it for me …

Hope anyone was able to read through my ramblings and might be able to advise … else it is away from Scrivener yet again …

Happy Scrivenings

Update (so no one can say I did not try hard enough) -

I fed the survivng three scenes of the novel into a project template just “novel” (without the “parts” bit), created all the necessary folders and files and all that myself, so there were no such toys as a predefined “title” page, then compiled - and again got the “CHAPTER WHATEVERNUMBER” before each and every page break. How in the name of all that is holy can I get rid of those? It is soooo annoying - after all I am starting with a prologue rather than a chapter, and then come part, and THEN first chapters - and those will be in German anyway! There must be a way to switch that CHAPTER-business off once and for all, it is so getting up my youknowwhat.

Please please please find a solution, I love Scrivener for its unrivalled organizing and the fantabulous corkboard, but under the given circumstances I am having a very hard time accepting the shortcomings of it which might in the long run ruin my nerves completely …

I’m sure you’re aware that the Windows port of Scrivener is beta software and that, being beta, some things have yet to be implemented and there are bugs–some known, some unknown.

That being said, I feel your pain. I, too, have many issues with compilation. I am trying to produce Shunn Short Story format as that is the format required by the markets I’m currently targeting. I am unable to produce this (standard, honest, it’s used in many markets) format. So, believe me, I commiserate.

Even though the documentation is not up-to-date (did I mention this was beta software?), I would still recommend getting familiar with the compilation process and the compile dialog. This is documented in Chapter 19 of the Scrivener manual (F1 key or Help -> Scrivener Manual) starting with “19.3 Expanded Compile Interface.” I spent some time learning the ins and outs of the compile interface and created a template of my own that gets me close to what I need for short stories, but it’s still not 100%. There are still bugs.

If you don’t want page breaks before your chapters, turn them off. I’d suggest reading the documentation on how that is accomplished. That kind of thing seems to be working for me. My issues with compilation are:

(a) The output formats are not consistent. They all produce various differences.
(b) Shunn Short Story format,, requires double spaced text. The output formats I would prefer to use do not currently honor the spacing control and, therefore, produce single spaced text.
© Shunn Short Story format requires that separators are centered. Some output formats do not currently center separators.
© Shunn Short Story format requires both single and double spacing. This is the bug that scares me. If it isn’t fixed before release, I may not purchase and use Scrivener in the future. While text must be double spaced, separators require an initial single blank line, the centered separator line, and a subsequent single blank line. So far, the closest I can come is a double spaced separator. I find that unacceptable. Why? Because when I write long form novels, I cannot, or simply will not, perform the hundreds of edits required to take out the unwanted blank lines. That will be a “show stopper” bug for me.

I am hopeful that my compile issues will be resolved before release, but there are no guarantees.

But right now, I know that the compilation process has bugs and I’m working around them as best I can. Hopefully, you can find a productive middle ground in your usage of Scrivener as well, after reading the documentation.

Good luck.

Skyedreamer - As jravan points out, Scrivener is still in beta, and so in addition to some lingering bugs and missing features that Lee’s hammering out for the 1.0 release, I’m afraid the compile presets and templates are still a bit off as well. I’m sorry this has been so frustrating for you, but it should be fairly easy to fix the particular issue you’re having with the “Chapter #” prefix being added. If I understand correctly, you’ve already included that in the document titles themselves in the binder, so you simply want to remove the extra prefix everywhere it’s being added, correct?

Open the Compile settings and click the arrow button to the right of the “Format As” drop-down menu so that you can see all the options, then click on “Formatting” in the sidebar. In that pane, you’ll see a table at the top showing the different elements selected for each document type (folder, document stack, and single document) and level (where it is in the binder hierarchy). If you’re using the default compile settings for the Novel With Parts template, I believe the chapter numbering is being added on the single document level, but it may be different in your project depending when you created it as the settings have undergone some changes. Just click through each row and check what’s visible in the preview area below–if you see the unwanted “Chapter 1”, then keep that row selected and click the “Modify” button. That will bring up a panel to set the formatting for that row, and there you can click “Title Settings…” and delete the prefix from the window that pops up. You’ll then just get your binder titles compiling without that additional chapter numbering.

Once the templates are fixed up, you may find this a more useful feature, as the purpose is to allow you to title your documents whatever you like in the binder without having to include “Chapter #” right there–it makes it easier to move documents around without needing to renumber and, if you use descriptive titles for the documents, lets you see more of that wording rather than just the chapter number. At compile time, you can set which types and levels of documents have a prefix added, what the prefix is, etc. Documents marked “Compile As-Is” will not have the prefix added–so the title page shouldn’t get the prefix even if it normally would based on its type and level. That’s just a bug that will be fixed for the 1.0 release.

Regarding the page breaks, you probably just need to adjust the settings in the Separators pane of compile, but also check in the Contents pane to make sure you don’t have “Page Break Before” ticked anywhere you don’t want it.

jravan - Most of the issues you have noted are all on the list to be fixed before the 1.0 release. The separators should always be centered, line spacing should of course be honored, and the various formats should (to the extent the format or the exporter is capable) produce similar results. This last one will vary as necessary, so you may find for some special formatting that one export format is better than another, but for basic things like issues you’re seeing now where separators are centered in some formats and left-aligned in others or line spacing is observed in some and not in others, these should all be standardized. RTF (which DOC uses), PDF, and print will be top priorities for 1.0, but the issues will be addressed ultimately in all the formats.

As far as the difference in spacing that you require for the separators, that is not going to be addressed by 1.0. I understand that you need it for the submission format you have to adhere to (although I don’t see that in the page you linked, which just has the separator double-spaced like the rest of the manuscript), but it’s essentially an additional feature that would need to be added. When the spacing bugs are corrected, separators will use whatever spacing is used in the manuscript itself, and at present there isn’t an option to choose separate spacing for your separators. The ability to add a line break as part of the custom separator will be added (though it’ll likely be a a 1.x update, not part of the initial release), so that may help you to do a find/replace with styling after compile when you’re in a word processor.

Concerning separator spacing, I finally actually measured the spacing of the single “#” in the prototype short story manuscript on Shunn’s web site. You’re absolutely correct. The separator is simply double spaced.

As I understand it, this means there is only one fix for separators (for 1.0, at least). Compile must place the proper number of blank lines there during a compile. Which is to say, a user can’t produce the proper format (at least Shunn format) by hand through adding some number of blank lines at the beginning and end of text files. And that’s exactly what I am currently and unsuccessfully trying to do.

But knowing that these issues are on Lee’s list to fix before release is very helpful.

Thanks for replying, Jennifer. It’s much appreciated.

Thanks jrvan and mm for the replies!
I have last night found a workaround by using the “Times 12pt with Bold Folder Titles” Format option instead of novel manuscript standard format. At least that gets rid og the Chapter numbering, but it still requires a lot of tweaking after compile.

I know this is still a beta and I do appreciate what a lot of hard work goes into finding and addressing bugs. (I was not even aware this was still a bug anyway, I thought it was just me unable to figure out how it is done properly. It being a bug still to be addressed was a mere hope towards my own sanity really.) But when after some outlining and scene writing I then discover that the compile messes it up, KNOWING it is a bug does not help my frustration. (I am by the way using the very latest beta - every time I get frustrated I delete all traces of scrivener from my PC, only to then download the latest version when I decide to give it another shot … :wink: - which was two days ago if someone asks :wink: ).

Thing is also, compiling SHOULD BE far from my mind, as three out of a hundred scenes have so far been written. That said, I love testing things, plus another thing I like doing is to compile as soon as a measurable amount of writing has been done, convert to MOBI format and then read it in bed on the kindle - which makes proof-reading far more efficient, as it feels like reading a real book, and this makes spotting spelling errors and weird phrases or timing mistakes or the likes much easier, it feels a lot less like reading my own stuff rather than someone else’s …

Seeing as questions are taken serious and are dealt with right away in this forum, I am prepared to stick with it a bit longer … as I said, I love the functionality of it, it is just that late at night being confronted with such issues, when one thinks about going to sleep, is painful. I was harsh yesterday. Sorry. :blush:

Hi, I’m a new Scrivener user, on the Mac platform rather than Windows, and I’ve been having the same problems as Skydreamer with the “Novel (with parts)” template and compiling. I tried following the notes on changing compile settings but to be honest… I can’t even FIND where the compile settings are located within Scrivener (and believe me, I’ve looked under Preferences and everywhere else I could think of). I swear I’m no novice to using a computer but this is frustrating. My book is most definitely in three parts and I really need to figure out how to get this working effectively. Other writers I know rave about Scrivener so I was very hopeful this would be a good tool for my writing productivity – but if I have to spend hours trying to figure out things like this, I’ll never finish this darn book! :laughing:

Appreciate any practical tips and advice you can offer this Scrivener rookie.