Compile. Problems with Titles and Levels

Hi, everyone

Please, need some help.

I want to compile a folder as a book, with its own index. As you can see in the screenshot, I have Level 2 selected and that´s exactly how I want the index, but in the text box I don´t how to remove “CAPÍTULO UNO”.

Other thing, every time I compile settings somehow come back to factory settings. Is there a way to save the compilation settings I want?

Thanks!! :smiley:

Click on “Section Layout…” to edit the title prefix and suffix and get rid of the “CAPÍTULO <$t>” setting.

Compile automatically remembers the settings as long as you compile once changing the settings or hold the Option button down and click on the “Save” button (the “Compile” button becomes “Save” when Option is held down). It only forgets the settings if you hit “Cancel”. Also, if you choose a format from “Format As”, that will reset the settings to that preset. (Once you’ve changed the settings in any way, that will say “Custom”.)

Thanks, man. That was very useful.
However, I got a new problem. Please, see the image attached. Do you see the chapters are underline and with a line on the left? What´s wrong?

I don´t what is happing with Scrivener. Every time I compile is a nightmare! :cry:

Captura de pantalla 2015-03-05 a las 15.48.27.png

They’re underlined because they are links - you can turn that off by deselecting “Underline links” in the “HTML Settings” compile pane.

The dash is appearing because it still thinks you have a title prefix. Go back into “Section Layout…” and make sure that there is nothing at all in the “Title Prefix” box - my guess is that you have left an empty line or a space in there.

Many thanks, KB. All is working fine again, and the tip to save settings is magic…
Have a nice day.

Glad you got it all worked out! Incidentally, if you have everything set up in a way that you may want to use with other projects, you can select “Manage Compile Format Presets…” from the “Format As” pop-up menu and save the Compile settings so that they are available to all projects. (And you can export settings from there, too, in case you want to save them somewhere so that you never lose the settings even after a complete system reinstall.)

It appears I have not set up my chapters correctly in the Novel format so I’m having trouble compiling. Yikes! How can I change this to proceed to compile correctly.

  1. Title Page does not show complete title Gritty Circles: A Coming of Age In Detroit is complete title (only Gritty Cirlcles appears when compiling
  2. All my sections are flush left rather than indented. How do I change this
  3. I want to show:
    Title page
    Part One (etc.) (indent)
    Chapter name (indent)

Frustrated in Michigan