Compile Problems

I’m trying to compile one chapter of my book to pdf for a friend to read. That chapter is the only one marked ‘include in compile’. When i try and compile, it comes back with a ‘error while printing’ box and when you click ‘ok’ it aborts the compile.

Any suggestions on how to overcome this would be gratefully received.

Can you print normally from other Mac programs, like Mail or TextEdit? We use the standard printing system on the Mac, so if the configuration of that is messed up, it could halt Scrivener’s process.

Does PDF work as a compile option instead of Print?


Thanks for the suggestions. This only happens when i want to compile to PDF. Compiling to print was fine, no problem at all, but i can’t compile to PDF as i get the error message and when i click ok the compile is aborted.

Okay, what happens if you try another chapter entirely, excluding the current one? If that works, that could indicate a problem with the text in that file you are trying to export—maybe a stray bad character or something.

As a work-around, if you can compile to print you can print that file on the Mac using the “PDF-Save to PDF” (lower left hand of the Mac OS print dialog) in order to get a pdf.

I have tried again with the next chapter and have had the same error message and the compile aborting when i clicked ok.

I tried the work around suggested - using PDF-Save as PDF from within print, but that also generated an error message with the same result.

Okay, based on that (both how we create the PDF and the “Save as PDF” button are Mac features we make use of) it does sound like there is something wrong with the Mac. That’s probably something you’ll want to get fixed, but for the moment, you may have luck visiting the “Print Settings” compile option pane and switching the engine from “Publishing” to “Proofing”. This will cause Scrivener to use the Java converters to create the PDF, instead of Mac OS X. So in theory that should dodge any troubles with the Mac itself.

I’m a little confused that you think the problem is with my Mac. My Mac is less than a month old running the latest version of OS Mavericks, how can that be the problem? If i need to contact Apple about this can you give me some specifics i would need to tell them so they can sort this out please.

Also tried the work around you suggested changing the print options to proofing from publishing. This came up with an error message saying;

‘There was a problem creating the PDF file using the “Proofing” option, which uses a third-party library to generate the PDF data. Would you like to create the PDF file using Scrivener’s standard methods? (This is the same as using the “Publishing” option.)’ Any ideas?

I’m hoping to submit my novel to a number of competitions and publishers, at the moment all i can do is print it out. I would by grateful for ways around this or i am going to have to spend hours cutting and pasting into a word processing program. Thanks

You may want to check if you can print to PDF from any other application (Word, Pages, Safari, Mail, anything). Assuming that you can’t, that would provide ample evidence for Apple that there was something about your installation beyond any specific app. Anything beyond that I’ll leave to AmberV. I’ll also let him answer your questions about what might be going on behind the scenes with your Mac.

Note that, given your Mac is only a few weeks old, you will have free phone support from Apple and you can also make an appointment (for free) with an Apple Genius at any Apple store. Of those two options, I’d recommend the latter: my experiences of Apple phone support over the years are mixed (sometimes brilliant, often not), but the in-person service I have received at a Genius Bar has been consistently high.

In the meantime, if you want to get your manuscript into a word processor simply Compile to Word. Even if you don’t have Word, most Word processors will read Word documents. Compile is much easier than copy and paste! I compiled chapters dozens of times (if not more) when working on my thesis. Highly recommended.

I’d say “Compile to RTF” as you’re not using a third party converter to convert that to .doc or .docx. Word will open the RTF perfectly and saving it out as .doc/.docx from there is safer, I’d guess. The only reason I would use compiling to Word .doc/.docx is if I wanted to open it in the latest version of Pages, which won’t open RTF, though why anyone would want to use that, I can’t imagine.

Mr X

Update - Exported a document to pdf, opened it in preview and then printed out the pdf, all worked fine. If that works, should Scrivener be able to compile to pdf as well?

What were the steps you took to create the PDF initially, in order to open it in Preview? I thought that is the one thing you couldn’t do. I’m also not sure what printing from Preview tests, since you mentioned being able to print from Scrivener as well. I would expect that to work, it’s whether or not something like TextEdit can generate a PDF from a print job using the “Save as PDF” button, since that seems to be what malfunctioned in Scrivener.

As for where the problem is, I’d say it’s still up in the air. The reason for my leaning toward it being a Mac problem is that the “Save as PDF” button is about as Mac as Finder is, we really don’t have anything to do with that button, save for the content that is delivered to that panel. However, the fact that the “Proofing” engine also failed lends credence to it being some kind of content-related issue, but how that managed to survive all the way to the “Save as PDF” button is mysterious to me.

Have you tried creating a new blank project, typing in a line of junk text, and compiling that to PDF?

But as noted above, you aren’t without options—PDF output from Scrivener was originally only intended for personal proofing anyway. Compiling as RTF will give you a file that works in nearly any modern word processor, and most of these will be using their own text engines and PDF generators, so you’d dodge anything endemic on the system—assuming that’s the problem.


Thanks for the reply. I tried to create a new document to test as you suggested and got the following:
“The project could not be created at ‘/Users/Simon/Documents/Test.scriv’. Please check you have enough free disk space and the correct permissions to write to this location”
The problems i’m having seem to have occurred since i migrated my Scrivener content to my new Macbook Pro from my Macbook Air. Is there anyway around this without loosing the work i have done since the migrate?

Thanks for your help.

I would check those two things to make sure they are okay. The disk probably isn’t full since it is new, but permission problems can make can make the computer act funny all around. If you used the Apple Migrate thing to transfer, that has been known to not always get permissions set right. I would run fix permissions with Disk Utility, and check the Documents folder to see if you can write to it.