Compile Scriv 3 Win No paragraph spacing

Whenever I compile for docx or rtf in Windows 3, all of my paragraph spacing disappears.

I imported a project from Scriv 1 to 3 for Windows, and I’m trying to compile using the imported scriv 1 compile settings. I have double-checked the formatting for headings/sections/section starts, and when I go into the layout window in compile, each text or folder group has the sample paragraph text indented. This is true for every section layout. I also have checked the box “override text and notes formatting” and the box “preserve indents” in compile.

Nothing helps. There are no line returns + indents in any of my document. I don’t know what to do next to fix this. Could someone help?

For clarification: This problem also appears when I try to compile using the “default” setting, where all of the text is supposed to appear as it does in the editor.

Have you examined the text itself with invisible characters shown (View ▸ Text Editing ▸ Show Invisibles)? What you would want to see are symbols at the end of every line. If you’re getting symbols instead, then your text is essentially one very long paragraph with multiple lines in it. I don’t know how or why that would have worked for you in the past, as that would never be a desirable setup, but who knows.

Of course it would also be good to test sample data as well. Maybe add a new empty entry to the very top of the Draft and type in three new lines into it, using copy and paste to bulk them up a bit to paragraph length.

Hi Amber,
Thanks for your suggestions. I tried both suggestions, to no avail.
I do have paragraph symbols at the end of every line. I also tried creating and compiling a new text document, but I still have the same problem.

Okay, could you send or post a short example of your configuration? It sounds like you can reproduce this issue with test data, so what you might try is using Save As to create a copy of the project you can strip all personal info from and just leave enough dummy text to demonstrate the problem. Or if you prefer, you could send the original project to technical support where it will be kept confidential. Just be sure to paste the forum URL for this thread into your email.

I’m not really sure how to do what you describe on purpose even, hence why I think this might be easier to convey by example.

Has this been answered? I’m having the same issue. This is a file I moved from Scrivener 1 into Scrivener 3 on Windows. I have hard paragraph returns. I’ve scoured compile settings, but most of my paragraph breaks are gone. The only time it seems to work is if I have two spaces at the end of the previous paragraph (though it doesn’t indent the new paragraph).

Until this is fixed, is there a way to revert back to Scrivener 1?

I don’t believe they ever got back with us, so I’m not sure what was going on.

In that case it sounds like me like you’ve turned on MultiMarkdown conversion. Check in the General Options tab, on the right hand side of the compile overview window. If you aren’t actually writing in Markdown, you should switch off the Convert MultiMarkdown to rich text setting. Markdown requires an empty line between paragraphs, and will insert single line breaks for lines that end in two spaces. Line breaks cut the paragraph in two, so it wouldn’t be using any first-line indent in that case.

I am using markdown to covert _ _ and ** ** into italics and bold so that I could copy between Google Docs and Scrivener a not worry about formatting. Yes, if I turn it off, the paragraphs come back but then the bold and italics don’t converted. This worked fine in the previous version.
I’ve gone back to the previous at by copying and pasting all the sections…though I would love a better resolution that allowed me to use the version I paid for.

This setting works fine in this version as well, you were just expecting a different setting that no longer exists. These are different things.

You could try running a Replacement that converts one carriage return into two. (Actually it looks like that still doesn’t work for some reason—well, it’s something you could do to the source text anyway with search and replace.)

When I said this was working in the previous version, I meant the ability to use these markdowns and get italics AND paragraphs on compile, not a particular setting. If I had known that funtionality did not exist is the new version, I would not have spent the money to upgrade.
As for finding the hard returns and replacing with 2, A) I don’t want double-carriage returns in the editor, and B) where’s the option to do that…do you mean manually going through my entire manuscript and adding a new line after each paragraph?

Hi, jamjari, I didn’t get back to L&L earlier.

The problem you describe is exactly the same as the one I was having. Yes, markdowns AND paragraphs on compile worked (and still do) in Scrivener 1.

I feel the same level of frustration… I’m not going through a 96K word manuscript to do this. Fortunately, I caught this 2-3 days after switching to Scrivener 3. My solution was to waste a day of my time with my Scrivener 1 manuscript version, painstakingly copying the changes I’d made in Scrivener 3 back to Scrivener 1.

@L&L: This a huge turnoff to your new product, and I sincerely hope you will find a way to correct this, so that Scrivener 1 to 3 conversions are not impossible.

1 Like

Yes, this is something would feel really needs to get fixed, Ioa – Markdown to Google Docs is a prominent pathway used here for consulting with an EU university, and I would like to use Scrivener for increasingly complex documents…thanks :slight_smile:

I know it’s too late for you to use this now, but for anyone reading this thread, a Scrivener 3 project can export itself back to Scrivener 1 format (File > Export > as Scrivener v1).



No. You can replace one newline with two everywhere and then, just in case some were already doubled, replace three newlines with two. I wouldn’t like that in the Editor, though. I use styles for bold and italics, rather than the markdown syntax.

I must not be understanding - I don’t see anywhere I can search for ¶ and replace it with ¶¶. The only way I can see to do it is to go through manually. But, as mentioned, I also don’t want all those extra spaces between paragraphs, so for now I’ve gone back to Scrivener 1.

First (to make it a tiny bit easier), show Invisibles with alt-shift-V. Find any paragraph mark, select it, and copy. Open project replace (or Find), paste into the first box, paste twice in the second box, and click Replace. That said, I wouldn’t tolerate the Editor looking that way, either.

I’d use a bold style and an italics style. But that’s tedious if you already have a lot of bold and italics to convert, of course.

What is the Googled Docs issue, though? You can’t compile rich text to Word and transfer that to GD?

1 Like

Depending on what you need, I would even take it a step further:

  1. Use File ▸ Back Up ▸ Back Up To... and save a quick “pre-conversion” copy somewhere safe.
  2. Select the entirety of the draft folder, and open the Edit ▸ Find ▸ Project Replace... tool.
  3. Make sure the settings are such that only the selected items are changed, and within them, only the main text, and otherwise supply the carriage return replacements.

Sorry to have left anyone with the impression that Scrivener would require one to manually, by hand, pound on the Enter key several thousand times.

As for the resulting look, it’s a matter of taste. I can’t work with paragraphs all scrunched up together like word processors tend to prefer. I like to read that way, but when it comes to editing and writing, I want paragraphs to be distinct and visually obvious. Plus, I’ve been writing in plain-text since I started writing, and whatever writing I don’t do in Scrivener is in Markdown as well. So I hardly even notice it. I would even speculate that the difference is the sort of thing one might feel when trying soy milk for the first time. If you compare it to cow milk, you might think it tastes gross and is a poor alternative. Give it six months without ever going to the udder though, and you might find that a cold glass of dairy milk is the thing you find revolting. :slight_smile:

I.e. I could probably acclimate to scrunched up paragraphs too.

She mentioned having copy and paste issues between the two tools (and that’s not terribly surprising, clipboards between browsers and diverse rich text editors can be a fickle thing that may even start or stop working over the years), not compiling issues. One of the advantages of using Markdown is that it is 100% impossible to lose your formatting when copying and pasting between software. So in other words, unless I’m reading her wrong, she uses Markdown in Google Docs as well.

Is Google Docs markdown aware, then?

I want to withdraw my comment this replies to, about apparent need for a fix.

I pored over the trail above, and with the special setting in Compile options to convert Markdown symbols to formatting, I got what I need – the ability to compose up a Markdown document using Scrivener’s reordering abilities, and then successfully emit it as a document Google Docs can import as formatted.

Not sure why there’s that extra setting, whico h is very well hidden – if I’ve selected a MultiMarkdown compile, surely character formatting should be included??

Anyway, it’s quite workable, once set up, and as usual, thanks, Ioa and team :slight_smile:

p.s. normally I use Scrivener with its own formatting; the Markdown need is just for some EU consulting where I need to use it to share portions with or from others working in that format…