Compile SubFolders


I’m trying to compile a draft that has multiple levels of subfolders that don’t seem to export when I do a compile of the higher level folder. Am I doing something wrong? The subs don’t show up in the content pane, is this correct? What should I do?



Hi kip,

When you go to Compile Draft, it should pop up a pane to select all your settings, on the main “content” page of which will be a list of all the files and folders contained in the “Draft” folder of the binder. If the subfolders aren’t showing up there, double check in the binder to make sure they’re actually folders within the Draft folder and not just folders created on the same level. If you click the reveal triangle next to the Draft folder to collapse everything within it, do your subfolders still show in the binder? If so, then you just need to move them into the Draft folder and you should solve your problem.

The other thing to check, if I misunderstood what you were saying about them not showing up in the pane, is to ensure that you’ve got all the “include” boxes checked. Documents with sub documents can be either folders or file groups, and how they get included (or not included) in the compile settings may be throwing you. (The “normal” files within folders or file groups should all be showing up and by default they’d be checked for inclusion, but if you have text within a folder or file group container, you might not be including that with your settings and so losing chunks of your writing.)

Those are my two ideas, anyway. :wink: Hope they help!