Compile Text Size Problem

I have been writing up a storm on Scrivener and the writing is going great. But every time I try to compile and print I get the same size text that I am writing in; very large. I understand, theoretically that even though I am writing in Georgia 18, I can print in Times New Roman 12.

Theoretically, I say. I have spent hours messing around with the compile settings, I must have tried a hundred different settings, shooting in the dark in the Section Layouts window: Chapter Number and Text, Heading, Text Section with Heading, Text Section, New Page, all to no avail. My printouts always come out in Georgia 18.

A workaround might be to go through every chapter and change the text to Times New Roman … but I can’t believe that is the best solution to my printing problems.

Can anyone give me a clue where I might be going wrong?

Wow! This is about the knottiest problem I have ever run into. More than a week now. I reread the tutorial all the way through today. Awkward at first, the compile format now make perfect sense to me.
The problem is that my printouts always end up in Georgia 18 no matter what I do. Big waste of paper.
I am now defining my section types and section layouts like a pro (Ha!). I have created a custom compile format using Courier 9 single spaced. Everything looks good in the middle section layouts pane, it’s definitely Courier 9, and I go to compile and view the results in preview, and there it is again. It never changes. It’s always Georgia 18.
What am I missing?

Have you checked that “Override text and notes formatting” is on?

[attachment=0]Screenshot 2021-01-02 at 22.15.53.png[/attachment]
:slight_smile:

Mark

Hey Mark,

I have tried checking that box and unchecking it multiple times. Doesn’t seem to make any difference.
I finally decided to start a whole new project and copy all the chapters from the old one. That seems to be working for me. I never did figure out why the first project wouldn’t budge from Georgia 18.
Thanks for your input.
Phil

Were you using a body style? It’s hard to be sure without looking at the project, but that’s one of the only things I can think of that would cause the “override” setting to be ignored.

(You could also be changing the formatting for the wrong Section Layout, I guess. And if you’re compiling to an ebook format, the reader software can override whatever the author chooses.)

Katherine

So I usually compile straight to Word, this is the first time I’ve tried to compile to a PDF and was having this same problem.

“Override text and notes formatting” is on, that’s not the issue as the OP tested and confirmed.

The issue is if you use Styles. As I understand it, Styles are used to call out formatting that’s different from the default format for your text. The default format (No Style) is what the Compile process will override when/if the above setting is checked.

Anything set as a specific Style will not be overridden by Compile because you’ve essentially told Scrivener that you want that item of text to have a specific formatting that isn’t to be changed.

Thought I would leave this answer since Katherine @kewms has it right but I needed a bit more detail to really understand it.

1 Like

Yes, that’s it exactly.

I would add to this to check the dropdown, as unless you want things like block quotes or other such paragraphs to have a different font and size as the rest of the text, you should set your style to paragraph set up only, unclicking font family and font size.

:slight_smile:
Mark

1 Like

You can override a style in Compile by adding it in the Styles pane (of Compile) and modifying its format. That creates a new version of that style, but applied only in Compile.

2 Likes

Of course you can. but if you set your styles properly in the editor you can save yourself that hassle!

1 Like

I didn’t know you could do that, thank you @drmajorbob, I’ll test that today. That would be a better option for me because I do want to use Styles but have the final compiled font overridden.

Mark, thanks for your tip…combined with @drmajorbob, you’ve both led me to a far simpler solution.

I’m not sure what you mean by “if you set your styles properly in the editor…to paragraph set up only, unclicking font family and font size” since the whole point of this exercise is to use a different font family and size which gets overriden in the Compile.

For a bit of background to make sense of this struggle:

I’ve been using Scrivener for 6 years and I’ve never had this problem. The reason being, I write in a font I prefer which is set as the default - i.e. No Style. I then compile in my editor’s preferred font. Because No Style is set throughout the Project, the font changes to her preference during Compile.

Now I’m co-writing with an author who has dyslexia (but also uses Scrivener). After writing in my preferred font (No Style), I have to change to a larger, dyslexia-friendly font before sending the .scriv file to him. I do that with a Style in his preferred Font Family/Size.

Now it’s finished and we’re compiling for the editor, I have to change the project from his Style to the editor’s preferred Font Family/Size.

I worked around the issue by changing every Chapter back to No Style before compiling. A quick change using Scrivenings, but that changes all the other Styles too (we have Headings in each chapter) and it’s over 50 chapters long. Ideally, I want to change in Compile.

@drmajorbob is bob on… :grin: import the Style into the Styles section of the Compile Format and change it there. But from your tip, Mark, I don’t need to modify its format and create a new version of the Style, I simply need to uncheck the Include Font Family and Include Font Size boxes:

Bingo! Problem solved. Thanks for the tips from you both.

p.s. I’ve written this solution out in a lot of detail to aid anyone down the line who’s less familiar with Scrivener.

1 Like

Hi,

I didn’t know about your co-authorship problem; that puts a different dimension on it.

I suppose there are two ways of going about it:

  1. As you do, use a style that your collaborator can work with, and then set the compiler to override the font and size with the editor’s preference.

  2. In Project Settings > Formatting > set “Use different default formatting for new documents in this project”, and while you’re working on it set it to your preferred font and size. When you send the project to him, change it to the larger font for him, select all documents in the binder and use Documents > Convert > Text to Default Formatting. When you get it back, just do the reverse to change it back to your preference.

I think that, given where you are in the process, your (Dr Major Bob’s) way is probably easier. Going forward, the advantage of the second option is that all the text remains in “No Style”. When you combine that with setting any paragraph styles, e.g. Block Quote, to only retain margins, indents and line and paragraph spacing…

SCR-20240515-kvgc

it means not having to set up any style overrides in the Compiler.

That said:

  1. I don’t have any headings in the text in the editor; all headings are created from binder titles, so I do have Heading 1 to Heading 4 styles set up there.

  2. And this is perhaps peculiar to me—I essentially use styles as a kind of mark-up, so I always compile to a standard set-up, open the resulting document in my word processor and use a macro to modify the styles for the intended purpose of that document.

:slight_smile:
Mark

Just had another thought on Option 2 above: set Project Settings > Formatting to the font and size needed by your co-author. While you are working on it have “Use different default formatting for new documents in this project” switched off; when you are about to send it to him, switch it on and use Documents > Convert > Text to Default Formatting. When he sends it back, switch if off and convert again.

That is if you are planning to co-author any more books with him. :slight_smile:

1 Like

Yes, it’s put a different dimension on a lot of things, a completely new way of working for me which has been a challenge but an awful lot of fun, too.

Thanks for your help, Mark, it’s really helped to make sense of this. And down the line, it’ll save me a lot of time. I’m always learning new capabilities of Scrivener…they really have thought of every scenario!

2 Likes