Compile to docx adding extra space between paragraphs

I keep seeing this issue in various forums and reddit threads, but I’m not clear on how/if folks are fixing it.

Issue:
I have one project that when compiling, adds a space in between paragraphs.

Details:

  • I’m on Scrivener for Mac, version 3.3.6
  • Project settings are “No Style”, Spacing = 2.0, Inter-line spacing = 0.0, Paragraph spacing = 0.0
  • Issue occurs when compiling using Default, to Word .docx; PDF spacing is fine
  • Issue also occurs when compiling using my own compiling formats, where I “override” the text settings and set to the same parameters as my project, noted above
    When I click View–>Text editing–>Show invisibles it shows only one paragraph symbol at the end of the line, and then follows the one indent/tab I have at .5 inches. When in the project, I click enter at the end of a paragraph, then tab over once to start a new paragraph
  • It’s only one newer project with this issue. I have older projects that compile to Word just fine using the Default setting
1 Like

Hi praha3, and welcome to the forum.

Finding the cause of added spaces can sometimes be a bit tricky without seeing a copy of the project to review its compile settings.

Are these unwanted extra lines occurring between paragraphs from a single document in the binder? Or, are they occurring between two different documents in the binder?

I ask because if these additional spaces are between documents, it could be the compile separators coming into play.

If they’re falling within a single document, then I’d be curious if this particular project has different settings in the Project > Project Settings > Formatting panel that might be a factor.

I’d also caution you not to use the Tab key to indent the text. Instead, the better approach in Scrivener is to use the Scrivener > Preferences/Settings > Editing > Formatting panel and place the T-shaped marker where you want the paragraph indents to fall.

That will give you more flexibility and control in the compile tools for formatting your indents or removing them from first paragraphs if needed.

1 Like

Hi, thanks for the response! I did some trouble shooting and the issue seems only to occur when I export to a .docx. At this point I believe there’s some setting in Word that’s causing this to happen (though it doesn’t happen with all my Scrivener docs.) I tried changing the Normal.dotm in Word, but that had no effect. At any rate, I’ll just keep changing the paragraph spacing manually in Word.

I’m having the same problem. It’s only with .docx - .doc is as it should be.

Old projects and new ones both due this now. It did not happen before… whenever before was.

I don’t know if this helps, but it appears that Scrivener is feeding Word a new “Normal” style when it sends the file to .docx. This style has an 8 point buffer between paragraphs that default Normal style in Word does not have. Not sure where that’s happening.

I can confirm the same issue, which also only happens with .docx files. That said, I’ve also noticed that it seems to happen only when I compile certain selected text levels. I’m working on my dissertation (so I’d really love to not have to mess with formatting problems!) and it seems to happen when I’m compiling only certain selections and not when compiling the whole document. This is good news of course, if you don’t count the added time and frustration that I’ve endured trying to figure out what it was adding an extra 7.92 pt (not 8) after each line in .docx files!

Should be “why it was adding an extra” not “what”