Compile to Word

Just downloaded 25, and ran the Compile to Word document. Yow. It could be me, or my existing files, but when I use the Standard Manuscript format, I get pages with just one letter per line. In other words, my words run down the page, instead of across, but only one line deep. So my five chapters turns out to be thousands of pages long. It could be I’m doing something wrong, but it seems to be the same problem if I save to RTF as well. Compiling to .PDF is not a problem. I couldn’t compile to MOBI, but I think that’s because I named all my scenes Scene One, Scene Two, etc.

I compiled to word (doc) just fine, it looks normal to me.
using version .25 as well.

ETA compiling to .docx worked fine also.

It’s quite possible that I’ve done something wrong. But I was using it just fine in 24, and didn’t see any issues. For what it’s worth, I uninstalled 24 from the Add remove programs, and installed fresh. This is running on XP.

I noted that when I save to HTML, it appears as I expect, just like PDF. MOBI, once I changed my scene names to unique names, it compiled.

Just to play it safe, I created a new project from the default Novel template, copied the text from one chapter over to the new project into one document, and tried to Compile to Word doc. Got the same results. I haven’t tried rebooting or reinstalling yet. I might try both, just to see.

I have the same problem, but then I also had it it version 24. I thought it was going to be fixed in the next version, but apparently not, which is a big disappointment. I’ve found it’s possible to rejig the margins in the compiled document without too much bother, but still…

Hi guys,

Sorry about this. Lee did a bunch of work on this just before pushing out the 025 beta, so we’d thought it was fixed, or mostly fixed at least. Let me poke at it a little and see if I can find the fix for you–I think it may just be an issue of resetting your compile options, but it may need something else for older projects. I am seeing it as well, so we’ll keep working on this.

When you’re running the compile on an older project, did you keep the original compile settings that you had from the earlier version of the project, or did you redo them–specifically the formatting options–or choose a different pre-defined option from the Format As drop-down menu? In the formatting tab, are you checking the box to override formatting? And finally, what elements are you compiling?

Hey Jennifer,
I’m getting this same error on out put to .doc with an existing project, but also with a project created using 2.5 with text pasted in from Notepad, using the ‘Novel Standard Manuscript Format,’ so it doesn’t seem to be project specific.

All right, it looks like something happened with the compile formatting code so that overriding the formatting will give you this, unless you set the right indent to about 4.4" or less (somewhere on the ruler in the sample). Melessa, when you did the compile that worked, did you have the “override formatting” box checked?

I’m working on coming up with a temporary fix for this, but so far I don’t have anything terribly great to offer. The issue definitely appears to be–at least for new projects–confined to the compile formatting, so if you compile without overriding formatting, you should be okay.

Alternatively you could override the formatting and then correct the indent in your word processor in the compiled document–the right indent tab in the ruler is hidden behind the paragraph indent tab all the way on the left, but if you drag the paragraph indent tabs left, you should be able to then get at the right indent and pull it over to where it’s supposed to be:
That seems to only work if you have a first-line indent, though. It might be worthwhile to specifically set the right-indent in the compile settings to the 4.4" or whatever–it will then compile with that, which is not what you want, but it’s much easier to grab the indent marker and fix it from there.

I apologize for this, guys–I know this has been a problem for a while, and Lee really thought he’d got it for this build, so I suspect something just happened last-minute that broke it. I’ve let him know, and if I come up with a better workaround I’ll be sure to share. If anyone one else comes up with a solution, I’m all ears.

no, I unchecked it when it was undoing my italics, which needed to be italicized for the story.

Alas, changing the margins doesn’t really work. To change them all at once, I should be able to select All. But when I do that, it shows the correct margins for the titles instead of the bad ones for the text. The only way I’ve been able to change them is to select the problem text only, which means on a scene by scene basis. Given that my manuscript is over 1,700 pages long at the moment, this is not happening.

I have found a way to fix this that works for me - I set the right margin in the default text format (the Nietzsche quote) to a suitable fixed position (16-18cm) rather than something way off to the right which makes it float. Then convert all documents to the default. This compiles with sensible margins in rtf and docx modes (haven’t checked everything). Sadly, I then lose the floating right margin within Scrivener, so even full screen, I still get fixed line lengths. All of this has the ‘Override text…’ option UNchecked in the compile (I haven’t experimented with checking it).

The compile still has problems - I can’t get the titles included, and the page break before each document happens before the last paragraph of the previous document, which then runs on into the first paragraph of the next one, but this is a lesser problem.

EDIT: I see that MrDither has already addressed this. It’s to do with setting ‘page break before’ both at the document level and as a general compile rule. If I change the compile rule to ‘empty line’, but leave ‘page break before’ on the document, I now get no page break at all (but this is marginally better than concatenating paragraphs).

If you’re leaving “override text and notes formatting” unchecked in the compile settings, you don’t need to change your right indent within the editor. The problem is coming in with the formatting set in compile, so if you don’t override the formatting it will use your editor settings for each document and leave the right indent alone. Titles aren’t getting compiled properly in that case though, and I’ve let Lee know about that. He’s working to get this fixed and intends to release an update within the next few days to correct the issue.

Thank you for pointing out the page break issues, I’ll look into that a little more too and again, pass it on to Lee.

That might seem logical, but it ain’t so. If I change the default right margin away off to the right, and convert a few documents to that format and then compile, I get the one word per line issue on the documents I converted (ie the ones with the floating right margin in the editor). The documents with the fixed right margin in the editor compile OK.

If I then check the ‘override text…’ option when I compile, then the entire manuscript comes out with one word per line. But yay! I get titles. :slight_smile:

Tell Lee to have fun… (I’m a software developer by trade myself, I know what he’s going through.)

Drat, I see it. Sorry I missed that–if you’ve redefined the formatting in the Options then it gets this same indent issue and although dragging the indent back all the way to the right makes it appear correctly in the editor, you do get the wrong code in the underlying file. If you reset the Options to the defaults, this will be fixed (and you can then convert your existing documents to match the defaults), but obviously that will lose your other preference settings as well so it’s hardly ideal. Like I said, Lee’s fixing this and will have a new update in a few days, and I’ve let him know that the issue exists in both places.