Compile Window does not come up!!!

As reported elsewhere, I’ve been fiddling with layouts and pre-suffixes to create a layout suitable for GitHub pages.

I’ve been changing my prefixes from, e.g. <$n:prev> to <$n#prev>, and the reverse.

Suddenly, after editing a layout, when I’d press save, it wouldn’t save, but I could cancel. After trying that again, I noticed I had three copies of my layout, two with yellow error tags. I deleted the two error ones.

The remaining one said there were no layout assignments, and when I went to assign them, the preview was wrong: empty. When I went to view the prefix / suffix, they were there and looked correct.

Then I went to compile and the compile window doesn’t come up at all. I closed the file and reopened, and the compile still doesn’t come up at all.

I’m going to exit Scrivener and restart it … it came up with my same file open, as expected. Still won’t open compile. (The File menu highlights briefly, and then unhighlights.)

Close project, close Scrivener, reopen Scrivener, reopen project … seems to open OK. Compile still does not open the compile window.

This is not good. Version is 3.02 (1506) in trial mode on this computer because I’m not sure how to give it my license from the home computer.

Please advise ASAP.

It sounds like something you have done in the formats is causing Scrivener to throw an error. Please zip up the project and either attach it here or send it to AT, marking it for my attention.

Thanks … Recent backups may be OK but IDK offhand how to restore them. Anyway I’ll wait for feedback here. (692 KB)

This isn’t the kind of solution Keith can provide, but if you need to get back into your project, the attached version now opens and compiles.

I just opened the project’s contents in Finder and removed the custom compile formats, which seemed to be blocking compile from running. Not the right thing to do, of course, in normal circumstances. (710 KB)

By removing the “New File RJ” layout from the compile file, the project now opens and compiles using your “MultiFile Output” settings. So, some of your compile settings are available in this version of the project. (715 KB)

What’s strange is that Compile is opening fine for me even with “New File RJ” in there. I’ll ask Ioa to see if he can reproduce it - strange it’s happening for both of you but not for me.

Are you using 3.0.3, you lucky developer?

Well I am, but obviously I tested on 3.0.2 too. :slight_smile:

EDIT: Wait, no, I tested on 3.0.1 by mistake. In 3.0.2 I can reproduce it. So it seems to be fixed in 3.0.3.

Such a tease.

Amazing and rapid response, folks, thanks!

So it sounds like I should D/L the Motion-2 files and start using those?

The good news on that is that after trying all the things I tried, I can probably devise a better set of layouts for the next try.
The bad news is that I may not be able to remember all the places I had to go and fiddle to get as far as I got.

Two more questions, please. (Narrator: Don’t believe him - he’ll have more.)

First, if this happens again, is there something I can do to get back in operation? Restore a backup or something? I don’t even know how I could have removed the layout that you removed: the only way I know to see it is inside of Compile.

Second, if you have (now or later) any sense of what I did that broke it, please warn me away from that. Sounds like it’s fixed in 3.0.3, so I’ll watch for that version.

Third, and this doesn’t belong here, so I’ll look elsewhere to see how to explain to my laptop what my license is.

Thanks again!