Compiled PDF won't open

I’m brand new to Scrivener – in fact, I just heard about this program last week and downloaded the trial three days ago. I’m using the program under the very generous trial terms. So far, I really like what I see. I’ve been going through the tutorial which has been every informative.

I’ve gotten to the section on compiling and hit a bit of a snag. I’ll continue on but I’d like to find out what’s going on with the one thing that didn’t work. I selected “Draft” in the Binder. Then I went to Compile and selected “Original” and “PDF” in the two drop-boxes as instructed, and hit Compile. It appeared to do the compile, asked me for a location and name for storing the file. All that seemed to work and the PDF file appeared with the proper name and everything looked good.

Then I tried to open the PDF file and Adobe Reader popped up a box that says: “Adobe Reader could not open ‘Scrivener-Draft.pdf’ because it is either not a supported file type or because the file has been damaged (for example, it was sent as an email attachment and wasn’t correctly decoded).”

So, that doesn’t help a lot. I believed I had followed all the instructions in the tutorial correctly so I did the compile again but changed to Rich-Text Format as the output. I then double-clicked on that file and it opened up in Word and it looked great.

Anyone have any idea what might be going wrong? I have version 10.1.12 of Adobe Reader X, if that helps.

I am also a newbie and having the same problem. My husband tried to open it with Firefox, same problem, then with Internet Explorer and got the message the file does not begin with %PDF. He also tried to compile as a word document and was successful. Is there any additional information on this? I like the program so far, but this would appear to be a major stumbling block.

Not being able to output a PDF isn’t a deal-breaker for me. If I can compile to mobi and to RTF, I think that will be fine. I did compile to mobe and got a file that reads nicely on my Kindle and on my Android Kindle app so I’m happy with that. But since it is supposed to be able to compile to PDF, I’d sort of like to find out why that isn’t working.

I am quite pleased with this program, overall. I think it’s pretty easy to use and has a lot of options for how the output should look and act – and ways to do the input as well including the option to have it do screenplay formatting. And for a decent price. FinalDraft is a lot more expensive and doesn’t really do anything but the screenwriting part. It may be more extensive for that, I’m not sure about what all it can do, but it’s 5 times the price and this is good for the book part that I want.

A total guess here - I’ve never done a PDF from scriv - but maybe this is a situation where you need to change the output converter for PDF?

Go to Tools | Options, click on the Import/Export option at the left, and then the export converters button.

In the new dialog box, change the To File Format option to PDF, and in the right drop down, whatever it currently says - pick the other option.


Like I said, no idea if that’ll help, but maybe worth a try.

Have you tried creating a PDF from a different project? Unless it’s just a problem with the PDF converter as SarsenLintel suggested, this seems most likely to be a project-specific issue, that some particular formatting in the project is causing a problem in the compiled PDF. It will help to narrow that down if you try compiling another project. Create a new blank project from File > New Project… and type some text in the document, then try compiling just as you did in the tutorial–just leave the “Format As” setting as it is and choose “PDF” for the compiled format. Does that produce a document Adobe can open?