Compiler compiles for PDF, refuses to print PDF

v11 - Compiling to PDF: “Preparing files,” check. “Compiling files,” check. “Printing,” no go. Scrivener stops/freezes half way while the PC whines and moans and the annoying little blue circle whirls. Or, Scrivener just closes. No PDF document produced. Works ok producing a Word dock. I’ve uninstalled, cleaned registry, reinstalled. No luck.

I’m unable to duplicate this , and everything seems to work well on my computer. I am using the latest licensed version of the professional Acrobat software though. I had to upgrade a couple of months ago from Acrobat X as it was falling over with an old version of Photoshop.


No problems, here, and I usually get hit with every nasty bug. Do you have anything in the file besides text?

Thanks, Andrew and garpu. Nothing in the draft except text. I’ve never had this problem before. Acrobat DC is functioning fine. At least I think so. I’ve cleaned the registry several times. I’ll check what services on PC are enabled and what are disabled. Anything related to Acrobat I’ll be sure is enabled. If problem persists, I’ll try uninstalling and reinstalling Acrobat DC.

OK, here’s the deal. I tried everything, including: reinstalling, Save and Rebuild Search Indexes, Text Tidying options, Convert Text to Default Formatting.

Finally, compiled to RTF. Then opened new project, imported the RTF file. So far, so good. Compiled to PDF. TaDa! It worked. There must have been something funky, corrupted in the original .scrivx file.

So now I have my work cut out to edit the imported document to achieve the original chapter, part, footnote, etc format. A PIA, but worth it. Hope this scenario might help others. Corrupted scrivx file in compiling to PDF, but no other compiling issues, only compiling to PDF. Strange.

This failing-to-print in PDF format issue is like Arnold. “I’ll be back.” After two days of clear sailing as a result of going through all I went through, my draft started again today not completing the Printing step after successfully completing the Compiling and Preparing. The program freezes, fails to print PDF. Time to submit a support ticket.

I submitted a support ticket about the compiler compiling a full document but not printing to PDF. (It turns out it will print several pages to PDF when, for example, a half-dozen pages are individually selected.) The support person responded in a timely and professional manner, but here is her reply:

Here I am in the Beta Testing sub-forum, not having seen, yet, a response from the developers. I hope that happens soon.

I have pinpointed the issue through numerous tests. Scrivener for Windows release 11 will not print to PDF if there is a page created as a table of contents thusly:

  1. highlight the pages of the manuscript/draft in the binder
  2. go to Edit/Copy Special/Copy Documents as ToC
  3. paste the results in a page (doesn’t matter what name you give it
  4. the result is a list of chapters as links

It is those links which prevent the entire draft from printing to PDF. It will compile, prepare for printing, and then Scrivener shuts down with nothing produced.

The very same draft with the ToC page with links will print fine to any other format.

If you want to keep the ToC page intact with the links that were created, and you want to print the draft to PDF, choose to not include that ToC page in the compile. Uncheck the box for that page.

This is a qualified bug. I have been told by the support staff that the developers review this Beta forum for issues and bugs like this. If a developer has in fact seen this post, I would appreciate seeing a response. Many thanks.

How are you preparing the PDF? I followed this process with a test Scrivener project and was able to compile to PDF just fine (test project and PDF are attached to this post)

Thanks @devinganger, for taking time to help. It is very much appreciated, especially since I’ve heard nada from the developers, and support directed me to the Beta forum so the developers would see it. Anyway, I am going by the (Scrivener) book, so to speak, to print to PDF. I am using only the Scrivener default formats.

And, since my last post, my so-called “pinpointing” the issue has fallen apart. Once again, nothing at all prints to PDF. I could give up and print only to Word, RTF, etc - but that’s not the point. Printing to PDF is an important tool and it doesn’t work for me.

Maybe it is something deep in the bowels of my Windows 10 PC, but I am otherwise having no problems at all with my PC. It has to be deep in the bowels of release 11. An appropriate metaphor. I suppose I’ll present this issue again in a new post in the Beta forum, but I’ll probably get blow-back for doing that. Whatever the cause may be, it should be addressed one way or the other by the fine folks at Literature & Latte, especially since people like you who want to help shouldn’t have to spend time doing just that - jumping through hoops to help.

But that’s part of the point of these forums in general and this beta forum in particular – peer support. We help each other by confirming if we see the same behavior, figuring out reliable reproductions, etc. so that the develops can focus their time on fixing the bugs. There have been many issues figured out here through this and previous beta tests where the devs just didn’t have the right configuration to see the issue initially trigger – and this is especially true in the Windows world, where we have so many different versions of Windows and hardware and third party software.

At any rate, let’s keep working the issue here and come up with either what’s different in your setup or a common set of repro steps!

First step – have you tried saving your Scrivener settings, then uninstalling and re-installing the beta? There may be some fluke of an issue with your setup solves itself with a re-install.

Thanks for the supportive words and the “we can do this” attitude. Yes, I have uninstalled, cleaned the registry, rebooted and reinstalled the latest release 3 times. As much as I wish to continue using Scrivener, I have always, always had issues with formatting, output, and of course the insane learning curve. I am one of the many people in forums all over the web who have said they spend more time learning Scrivener and dealing with bugs because the software is complicated.

I have spent many hours trying to suppress anger and frustration for matters over which I have no control. I’ll honor your good spirit and can-do attitude and see what happens in the days ahead with my issue, but I am preparing to test-drive other products. I’ve read some really good reviews of similar products from people who want to spend time writing and not being software experts. If formatting with any of the other products is as maddening and time-wasting as Scrivener, I may sharpen my #2 pencil and buy some legal pads. The last thing I want to do is go back to MS Word, which controls the writer instead of the writer controlling it.

Gee. Am I frustrated?

Thought I’d have another go trying to print to PDF. I chose a manuscript with multiple chapters. It opened in corkboard (as expected). Opened it in scrivenings mode and chose print current document. Changed print to PDF and hit print. Scrivener crashes.

OK - maybe you aren’t supposed to print a scrivenings ‘page’ but the menu lets you …

On the other hand, compiling to print and printing to PDF sort of works, although it fails to include the last couple of chapters - which are marked to be included in the compile ie 167 pages out of 201.

Compiling to docx first, and then printing from word to pdf works fine and gives me all 201 pages.

So there appears that there is something definately screwey with scrivener printing to PDF in my installation as well.

Andrew, I let out a sigh of relief upon reading your two posts for no other reason than to know I’m not the bogeyman. Thanks so much for experimenting, for having similar issues, and for confirming it is a release 11 bug. I have spent way too much time worrying that my PC, my Windows installation, my PC registry, etc. were screwed up. I too have thought about the compile to Word and then convert that to PDF workaround. But - we shouldn’t have to do that.

You are the man of the hour for me. Now I can walk away from my PC and not feel the helplessness that has afflicted me.

There must be a bug report submit process around here somewhere, right? Posting here for review by the devs, as was recommended by Scrivener Support, doesn’t seem to do be effective. I’ll hunt for it and submit a formal bug report.

Thanks again, Andrew!

Posting here is the formal bug report process. However, if you are willing to work with me (and any of the other regulars here) to hone it down to a precise set of repeatable steps to reproduce the problem, we’ll have a much better chance of getting one of the L&L staff members to read the report, reproduce it, and get it entered into their internal bug system.

Do you have the patience to tell me exactly what clicks, menu options, etc. you are using to cause the crash? Like I stated upthread when I first tried to reproduce this, I wasn’t sure what you meant by print to PDF – I was thinking compile it to a PDF and then print that PDF, but it sounds like you’re doing something different.

Hi Devin, I generally don’t use compile so missed the fact that you can compile to PDF. Just tested this and a compile to PDF just worked fine. But as I said, compiling to print, then printing to PDF lost the last couple of chapters.

Hi guys, the best thing to do is upload the project which fails compiling to PDF here(using a dummy text), or send the full project to tiho at literatureandlatte dot com, if you cannot reproduce the problem with a small demo project. Thanks!

Fascinating… I posted a few days ago about my issues with the compiler cutting off stuff when I went to make a .pdf through the print function. I did not realize that there was a built-in .pdf engine, and was using PDF X-Change as my printer.

Using “compile” straight to .pdf? No issues, no missing text. Huh.

It would appear that there is something wonky with the interaction between the .pdf engine that PDF X-Change uses, and the compiler.

Aha, okay. If you are using a third-party PDF printer engine when you say “print to PDF” – that is, you have your project open and you are selecting File, Print Current Document, and then as your printer you are selecting Microsoft’s Print to PDF or some other add-on PDF printer, then that has very little to do with Scrivener. Same with compiling to Print – when you select your printer and choose a print-to-PDF function, you may be selecting a third-party engine.

From the limited testing I have done, using the Microsoft “Print to PDF” and “Microsoft XPS Document Writer” I am not seeing the loss of any content using either of the above methods. I do not use third-party PDF-to-print engines like CutePDF or others like I did in the Windows XP days, now that Microsoft includes a decent one in Windows.

If this is where you are seeing the problem, you might want to try it with a couple of different print-to-PDF engines to confirm that it is not an issue with the selected print engine you are using.