Compiler treating sub-documents as Chapter Headings so not compiling the text

I have a project with everything selected as “Structure based” so all documents should default as “Headed Section”. Unfortunately the Compiler is treating them as “Chapter Heading” so when I try to compile the document text is not being included!
Thanks if you can tell me what might be wrong.

Yeah, you can tell from the preview tile that it is only generating a heading here. There will be some mock text below if it includes text. To fix that:

  1. Double-click on the preview tile in the middle column to open the format designer to this Section Layout’s settings.
  2. In the top half of the Section Layout pane you’ll see a row of checkboxes for each Layout. These determine what kind of content should be included. You want the Text checkbox to be ticked, and most likely the Title one as well, but from the preview it looks like that one is already enabled.
  3. Click Save, and you should now be seeing body text in the preview.

OK. Yes, that works as a temporary fix. But I really wanted the “Chapter Heading” section layout to be just that - the Title. As far as I can see in my Project Settings → Section Types → Default Types By Structure this is what I have at the Folder level but all my Documents should default to “Headed Section” which is not happening if the SectionType of the Document is set to “Structure-Based”.
So my query is: Why are my Documents not being set up in the Binder with SectionType = “Headed Section” ???

Oh, I misunderstood that this Layout is already working the way it should. The screenshot is a little blurry, but I think it looks to be using the correct Type, as you can see over in the right-hand column? If so, then the problem is that you are using the wrong layout for it?

  • This layout you have assigned right now is meant for headings.
  • Changing it is not ideal because this is how you want headings to work (folders).

If those assertions are correct, then click the Assign Section Layouts... button, below the preview column, and give the “Headed Section” type a different layout. If you started with one of the Basic MultiMarkdown/Pandoc formats when making your own, you should see one that is already set up with heading + text (in a very generic way). But if this is your own format from scratch, you should at least know now how to make a new Layout that has the right checkboxes ticked. Then once you have that made, you’ll be able to choose it from the Assign Section Layouts dialogue.

Hopefully that makes more sense.

Interpreting this a bit differently, my impression from the images is that the document file being compiled has the wrong section type being assigned automatically—it’s a single text file and should be Headed Chapter or something like that, based on the structure settings, but it’s showing as Chapter Heading. Since it’s being applied automatically as a structure-based setting (the grey italic of the name indicates that, vs. being manually set), the only thing I can think of is that one of its parent containers is overriding that with a default subdocument type.

So, working your way up the structure, try right-clicking the immediate parent folder and so on, then choose Section Type from the context menu and see if it has anything other than “Structure-Based” ticked under the Default Subdocument Type section. Setting it back to Structure-Based should then make the items beneath it that are set to “Structure-Based” section types go back to following the rules in the project settings.

Thank-you. Yes, you are right. I had a non-structure-based heading quite a long way higher up the hierarchy which was upsetting the way the default document type was being assigned. I think I’ve got it working fine now (and also managed to retain the non-structure-based heading - not sure how!).

1 Like