Compiling: Chapters do not start on their own page?


I just compiled a sample project. Each chapter sits on its own Document in my Manuscript folder. When I compiled it, the chapters do not start on their own page; instead they are tacked on to the end of the previous chapter.

Is there a way to force each separate document to have a page break before it?

The default Compile Appearance settings are set so that a page break is added before each folder. If each of your chapters are not divided by a folder, then you won’t get page breaks by default. However, all you need to do is create your own Appearance template (".scomp" file). In the “Appearances” list, hit “Edit” duplicate the format you like, choose where to save it, and tap on the “i” button to open the settings.

The settings use YAML syntax, which is human-readable even for non-coders and easy to edit. Scroll down to where it says “Document Breaks:” For instance, if you have duplicated and are editing the “Modern” Appearance, you will see:

[code]Document Breaks:

  • Page Break Before Folders
  • Line Break Between Folders
  • Line Break After Folders[/code]

Below this, you would need to add:

-Page Break Before Text Files

A list of all possible commands can be found by tapping on the question mark at the top of the Appearance Editor.

Essentially, you have a lot of control over the output of your compiled document. The five pre-provided ones are nice for a lot of projects, but also serve as an example for making your own.

Hope that helps.

All the best,


Thank you.

Don’t forget that you can always Compile from the desktop versions if necessary. That’s likely to be the best option for complicated documents for the foreseeable future.



I wish we could do ePub export from within iOS.