Compiling corrupts Scrivener file

I am using the Oct. 2018 version of Scrivener, Windows 10. Whenever I try to compile into Word, it corrupts my Scrivener file where it will open and then vanish. Luckily I no longer trust Scrivener and I keep backups of backups. If I can’t figure out why compiling is corrupting my Scrivener file, I will be forced to abandon Scrivener altogether, something I don’t want to do, :neutral_face:

Why do you using an older version then? Especially when you know it’s old?

Try installing a newer one, compile, and see what happens.


Thank you for your reply, I’m still left wondering how to fix my file. There are great things to say about Scrivener but support hasn’t been one of them. I have asked repeatedly for support on why my find function was working only haphazardly, I’ve asked why I can not highlight an entire section once I have it in the editing file and now I’m asking why I can’t compile…is there any real hope that simply going to latest version is going to fix everything.

Have you been asking in the forum? If you need a timely response, you should open a support ticket, which will reach an L&L employee. While we do wander through the forums on occasion, they are not our preferred support venue.

The Compile command should be completely non-destructive. No matter what happens to the output file, your original project should be fine. If it’s not, that’s a major bug that we would definitely want to know about. If you believe that you’ve encountered a major bug, though, the first step is always to make sure you have the most current version of the software.

Without knowing what happened to your file, it’s impossible to offer suggestions for fixing it, other than the somewhat generic advice to look at Scrivener’s automatic backups.

What do you mean by “vanish?” Scrivener opens then closes? The file (or part of it) disappears from your drive? Something else?


Where are you directing your compile output? And which Scrivener file are you referring to? A Scrivener project is a folder with lots of subfolders and files. Are you saving the compile output into the Scrivener project folder?

If you contact any support platform, including Microsoft or Apple one of the first questions they will ask is have you upgraded to the current version your system will support?

This is because the latest version (should) have all the bug fixes for issues identified to that point. Of course any software company is not interested in identifying and fixing issues in old versions of an app that aren’t being developed any further.

The version I am currently using (10/18). This is what happens: When I hit the command “Compile”, it freezes. When I attempt to go back into the program, it will load but any action on the screen and the program is gone. I am no longer able to load that file so that it will stay. However, as I said, I had a backup and I recovered my program but I can’t compile. I’ve noticed a list of “conflicts” under Files, Icons, Settings and Snaps shots (I thought this was normal) I work on the file on two different machines.

I don’t get to the point where it asks where to save to. I have successfully compiled int the past with no problem. I’ve tried to figure out what I am doing differently.

Does this happen on both machines and how are you synching between them?

The freeze-up happens on both machines. I updated my program to 1.9.15 10/19 but I haven’t tried the compile yet. I think I’ll try it on a copy of the file rather than my actual program.

I think you are confusing some terms. What file!?

As others have said, Scrivener projects, are not a file but a collection of files and folders, organized under one folder named after the project.

What ‘actual program’?

People have asked you specific questions on which you didn’t give answers. Did you read them at all? If not, we are wasting time, ours and yours.

If you really want a solution to your problem, start reading people’s responses and try explaining your issue in details. Talking about “a copy of the file rather than my actual program” doesn’t give us clues on how to help you.


When I’m talking about problems with Scrivener being corrupted by attempts to compile, and I say it is being corrupted. I presumed they knew what I meant was the Scrivener program is being corrupted.
I thank for the information on the unique aspects of Scrivener verbage… I’m more familiar with the broader meaning of file.
Sorry, but you lost me on what ‘actual program’ is it not clear that we are talking about the Scrivener program?
I have read each and every post, I have updated my program to the October 2019 and attempted another compile. At least this time it didn’t corrupt the program file, project, program or whatever we’re going to call it but it came back ‘no files selected’ On past compiles, I don’t recall have to specify which to compile.
“Talking about “a copy of the file rather than my actual program” doesn’t give us clues on how to help you.” I think that is pretty clear, I copied the program Scrivener, project or file or whatever we’re going call it and created a new project, file or program with a new file name and attempted that instead of using my main Scrivener file…there I go again using the term file instead of project. I will admit to certain ignorance regarding the division between program files and data…that has never been clear to me.

The Scrivener “program” is the Scrivener application, the thing that you download from our site.

The Scrivener “project” is the MyProject.scriv folder and all its contents, which include subfolders and potentially hundreds of component files.

A Scrivener “file” could refer to one of the component documents within the project, but from your posts so far it’s not actually clear what you mean, hence the confused responses from the people trying to help you.

If you believe that the program is corrupt, the first step is to reinstall it from a fresh download.

If you believe that a project is corrupt, you might consider restoring it from a backup. You might also consider creating a backup copy as part of your troubleshooting procedure.

Yes, the Compile command requires you to specify which files are selected. There are a number of ways in which a default selection might be defined for you, but the specification has to come from somewhere. Based on your symptoms, it is possible that the selection information is the source of your problems, and so having to start fresh with a new selection is a good thing.


I want to thank everyone for their help is resolving this issue. I have compiled to Word. There were a few bumps along the way, mostly over terminology but it’s done. To the extent that I can determine, the resolution was a two-step process; I thank those who advised updating my program. That is the step that seemed to fix the freezing up issue. It was my confusion regarding whether we were talking about updating or upgrading (I never thought just spending more money was the solution to problems.) But I updated to the current version and secondly, Katherine advised that it was indeed necessary to specify what files were to be included…silly me, I thought if you wanted to compile all, there would a checkbox for “all” rather than having to go through and check 297 individual scenes. For my moment on the floor, is there a way to carry over the scene numbers with the compile? Thanks again to everyone.

On the Mac, Option-Click selects everything. I’m not sure what it is in Windows – alt-click, maybe? – but there’s probably an equivalent command.