Compiling drafts

Trying to compile a draft and still having problems - the versions are still going past the edge of the page. Have tried adjusting the settings but I have no idea what to change them to. Any help would be appreciated, finding Scrivener more hassle than help at the moment.

Hi, docrum69! I’m not sure if I understand correctly the problem you’re experiencing. Is text overflowing your page size?

There are two different and seemingly independent page set-ups in Scrivener. One for compiling (Compile|Page settings) and another one under the File|Page setup menu.

It happened to me at first that fiddling with the compile settings had lots of collateral effects I did not understand. So I decided to load the default settings again in order to tweak one thing a a time.

Maybe if you can provide a more detailed explanation of what is going wrong for you I could come up with a more customized solution to propose. I’d be glad to.

[size=85]PS: I was also overwhelmed at first with so many options and this “Compile” thingy, completely new to my traditional MS*Word background. If you want to take another novice’s advise, don’t give up! I don’t like a hundred-pages sized manual either for a piece of software, but ultimately it ended up saving me a lot of time and steeping up the learning curve.[/size]

No matter I do, I can’t get the text to appear on a MS word/RTF document - it runs over by a word or two over the right edge. Getting frankly fed up, the manual has offered no help so far and Scrivener haven’t come back to me either. Hasn’t saved me any time yet!

This sounds like you may have set a specific right-indent for your text that is past the right margin.* Right-indents are mainly for special formatting like block quotations and script formatting, so they’re best used sparingly and handled directly in the editor applied to the specific text rather than set as a default for all documents in all projects or applied widely in compile. For most writing, and for your default settings, you’ll want to just leave the right indent affixed to the right edge of the ruler, effectively turning off the indent. To do this, just drag the right triangle marker all the way off the right edge of the ruler. If you make the editor wider (or widen the Options pane or compile formatting Modify pane, depending where you’re adjusting the ruler), you should see the right indent marker move with the edge of the ruler, indicating that it is just set to the margin and your text will wrap normally.

There are two places that your compiled text could be getting this indent from, so you’ll need to check the compile settings to determine where you need to fix the ruler. In Compile, click the blue arrow button to the right of the Format As drop-down menu if necessary to expand the window and show all the compile options. In the Formatting section, if “Override text and notes formatting” is checked, the ruler setting is coming from the settings here, and you’ll need to click into the appropriate row or rows in the table at the top to select the document type and level (for example, you’d click in the row with the icon of the single document labelled Level 1+ to adjust the formatting for all files in your Draft folder with that same single document icon), then click the “Modify” button above the preview area below to open a window where you can adjust the ruler settings. You could also choose a preset compile option from the Format As dialog to start over with more appropriate formatting settings.

If the “Override” option is unchecked (such as when using the “Original” preset), compiled documents are retaining their editor settings, so you’ll need to make the adjustments in the main editor, outside of compile. Close Compile and toggle on the editor ruler if necessary via Format > Show Ruler.

If the ruler settings are wrong for all your documents, it’s most likely that either they were imported (or were split from an imported document) or that your default editor settings have the right-indent set incorrectly. You’ll want to open the Editor tab of Tools > Options… and use the ruler there to adjust indent so future documents use the proper setting. Click OK to apply the changes and close the Options. Your new defaults will apply to all new documents you create (in any project), but you can now easily change your existing documents to match by selecting them in the binder (Ctrl- or Shift-click to select multiple) and then choosing Documents > Convert > Formatting to Default Text Style.

  • When compiled, indents will be based off the compiled margin settings (determined in the Page Settings section in the Compile window). In the editor you will see them indenting from the sides of the ruler–whatever the width of the ruler is–because the text simply wraps to the size of the editor, but consider the edges of the ruler as the inside edges of your final margin. If you have set the margin to 1in on the left, then a first line indent of .5in will ultimately put that at 1.5in from the left edge of the page when compiled. Likewise, if you set a right indent of 5in, and you compile with a 1in left margin, that would cause the text to wrap at 6in from the left of the page–compiling to 8.5x11in, that would put it 2.5in from the right edge. If the right indent is at 8in, compiling with 1in margins puts it at 9in, falling off the edge of your page.

In the preview panel, the text comes up fine with nothing missing. In the word document, the right indent is coming up as -6.35cm - no idea why it’s doing that.

The preview option in compile just shows the text formatting as much as possible; it does not display any page layout elements, so there are no margins, header, footer, etc. In future we’d like to do something more like the standard print preview here, but even then that would mainly apply to PDFs and printing, since the finaly display of formats like RTF will be influenced by what program is used to open them.

In any case, fixing the right indent as explained earlier should resolve the problem.

Thanks, seems to be sorted now

No, that doesn’t seem to be working when I try and compile the entire document.

Could you detail a bit more what you’ve tried (e.g. where you’ve changed the ruler settings and how you did so), what you’re compiling, and what the results are when you open the document in Word–e.g. is the right-indent incorrect for the entire text or only for certain sections? It’s difficult to offer specific help without more to go on.