Compiling results in file creation and immediate deletion

I am trying to compile (into ANY format, including printing) and the software creates a file, instantly deletes said file, and I am left with nothing showing. This includes printing as the software first creates a PDF for printing, and said PDF gets deleted instantly.

I have no clue why this is happening - I am trying with a single document, the entire manuscript, with and without front and back matter - nothing works. I am left with no way to compile my works…

Also - this does not matter what project I am using, including a fresh, brand-new project without any changes to anything.

** Note - I know the file is being created and deleted because when I compile, it triggers a Google Drive sync update that I can watch happening in the folder I am exporting the compile to.

Have you tried not to export the compile to Google Drive?

Please explain to me how one would not “export the compile to google drive?” I am literally ONLY compiling to a local directory that happens to be a part of my local sync to drive.

That said, if you mean compiling to a different directory, yes, I have, and yes, it still fails. I have also tried exporting using Scrivener 3 on a different PC with the same results. The file compile looks like it works, but then the file is deleted outright (and no, it does not stay in my recycle bin).

Just as an update - I uninstalled all copies of Scrivener 2 and 3, and reinstalled Scrivener 3. Compiling now works.

One more example of why to install the Scrivener Beta in its own directory if version 1.9 is installed. 1.9 is not bad, and 2.9 is not bad, but both of them together cause strange things to happen.

Just an update (because I did not update after the reinstall) - I have both 2 and 3 installed, in different directories (and did when I had them both installed before).

I found out that the template I was using was causing issues for the compile process - when I reinstalled the template, the compile issues returned. Removing the template restored compile capabilities. The compile issues were present in 2 and 3 with said template (which was a Scrivener 2 template).

Just so there is some final clarity and transparency to what actually caused the issue.

TL;DR - it wasn’t Scrivener itself that was causing the compile issues.

Thanks for the update! Could you upload a copy of the template? Or if you’d prefer, email it to with a link to this post? It might help us see what in the template is causing the issues.

Thanks for your help with this!

If I can find the template I downloaded sure. However, it should be pretty easy to find directly - Its KMWeiland’s novel writing template.

If that’s this one –, I think it’s designed for 1.9.x/2.0, and could cause issues in 3.

I advise taking her template (bare), selecting the entire binder, and dragging and dropping it, entire, into a new project in the Scriv Beta. Move the bits around so they’re arranged as expected (like putting research items into Scriv’s research folder, removing Scriv’s “Novel Format” document and moving hers into its place, etc). Then File -> Save as Template. I think there’s nothing in there that’s bound to break Scrivener (I could be wrong). It’s just that it’s a 1.9.x/2.0 template, and it doesn’t work with 3 so very well.

So I did all that (took maybe 5 minutes), reopened, compiled what was in there to docx (Word format), and the output is as expected.

For any who like that template, I made a conversion, asked KMWeiland to let me share it, and received permission. You can access it on Google Drive:

She may also share it on her site. It is still her copyrighted material, shared with permission.