compiling to epub trouble

with two days to publication of a book, I find that I can’t compile to ePub or mobi. The compile process proceeds as normal and then halts a little from the end (going by the progress bar) and it never moves from there. The same thing happens to other projects that compiled perfectly before

I have recently upgraded to Big Sur and have tried not only 3.2.1 and 3.2.2. I downloaded 3.1,5 but when I try to open that, it crashes

I’ve tried restarting my Mac and have now run out of options. Help please!

Make sure you’re using Scrivener 3.2.2 with Big Sur.

Are you able to compile to other formats (PDF? RTF?) successfully?


Hi Katherine,

thanks for replying.

I’m definitely using Scrivener 3.2.2 with Big Sur… I’ve also tried 3.2.1

I have even fired up my old MacBook and tried to compile on 3.1.2 on MacOS10.15.3 and that didn’t work. Strangely, even old books that I have compiled over the year successfully, didn’t work here either. That may be because 3.2.2 has changed their format in some way…?

no problem at all in producing PDF and RTF…

I had a similar issue a while back.

The way I narrowed it down was by cutting the project in half, over and over again. Eventually, I got part of the book to compile.

Then I took the half that stalled, and did the same thing. I narrowed it down to a single chapter, then a single document, then a single line.

Scrivener was choking on anything that had emphasis that was applied to a full line when the line did not break into a new line (IOW, if I included the paragraph pilcrow in the emphasis). I finally discovered that if I applied emphasis just to the word, it began to work.

I think Keith fixed that issue rather quickly. The last thing Keith wants, is for Scrivener to have issues, and he is dogged about fixing them if they pop up (thank you, Keith). And he appreciates when we help him by pointing him in a good direction.

Your issue may be something completely different. It may have nothing to do with Scrivener, and it may be a corruption in a doc or a paragraph or a word.

But it may be similar enough that if you apply these sorts of detective skills, you will figure out what is choking your compile.

So do what I did. Be Philip Marlowe for an afternoon. If you figure it out, post back.

thanks for that, Jack, though it does seem strange to me that 6 other books that I I have output through Scrivener successfully in the past few months—and published—now ‘choke’ in the compile…

I shall nevertheless attempt an investigation along the lines you suggest



Did you change something that those six books all have in common, like a bio page? If so, that’s the first place to look for problems.

Alternatively, try compiling with the Default Compile Format. That uses the simplest possible Compile settings. If it still chokes, it’s probably something in the text. If it doesn’t, it’s probably a problem with your Compile format.


I’ve tried all these things… and it always chokes.

I’ve managed to get 3.1.2 to run on my old MacBook and the book runs smoothly there. It seems to me that whatever is going on, it is something that has changed in 3.2.1 and 3.2.2 that doesn’t like something about my books that the previous version of Scrivener did. Not sure where to go from here…?

If you create a test project containing a single word, does that compile? If it doesn’t, can you zip that up and share it on this thread?

Will it compile if you choose a different output location?

here’s a a project with a single line that doesn’t compile on my system in 3.2.2 to EPub using ‘default’…

I was able to compile into pub 3 format. The file opened fine on my MacBook Pro (Big Sur 11.1 and Scrivener 3.2.2). However, when I sent it to IngramSpark, it returned a bunch of code errors. I recompiled in ePub 2 format and submitted. Ingram accepted it. Hopefully L&L can fix the issue before my April release.

Hello, Ricardo.

Initially, your project would not compile on my Mac.

I noticed you have a paragraph style that appears at the top of the style panel with a large # symbol.

If that style is deleted, the project compiles to ePub (on my Mac). So the style seems to be causing an exception.

Hope this helps.

Festive wishes


Renaming the style also works.

The # symbol in the name presumably causes an issue.

thanks again for your help, chaps

miraculously, changing the name (I actually deleted it because I no longer no why the “#” style was there) allowed my projects to compile just fine! It would seem that the upgraded Scrivener app must have changed something in the way it deals with Styles causing my problem. This explains why my Compile problem has not (apparently) been experienced more widely.

I did also notice that another thing that causes a Compile to choke is if you include an image that cannot be found. In 3.1.2 the compile went through and merely left a blank in place of the errant image…

thanks again… and wishing you all the best festive time possible


Glad to hear it is working.

Festive wishes