Compiling to .fdx

When I compile this page to .fdx…
1.jpg
… this is what it looks like in Final Draft.

2.jpg
The problem I have is with the right margin settings. In order to compensate for the Scrivener bug reported here where Courier font is displayed at the wrong pitch, I have set my Scrivener page width at 8 inches so that my Scrivener draft looks right on the page. But this means that when the draft is compiled to FD format, the right margin is off the visible page.

I then try to correct this in Final Draft by applying an FD template that has the correct margin settings. And at first it looks like there is no change. However, when I re-apply the FD element (in this screenshot, by putting the cursor on the first Action element and selecting Action in the drop-down), the line margin setting does in fact change. Note that the second Action element still has the original right margin setting. So the problem here is that I’ll have to go through the entire document changing each line individually.
4_2.jpg
I appreciate that you can’t give me support about using FD, but:
1: Any ideas for another work-round for the Scrivener font-scaling bug?
2: Any chance this bug is getting fixed soon?
3: Is there any way of compiling to Final Draft with different margin settings?
4: Do you think that the problem in FD is a bug in FD, or a problem in the .fdx file that Scrivener creates?

What I want to achieve is for the script to look right on the screen while I’m writing it in Scrivener, and then to get an .fdx file that I can print without having to reformat every single line. I’d appreciate any suggestions.

Any advice on this, please… :neutral_face:

Other than playing with the editor zoom, I haven’t any good ideas for a workaround. The problem is on our bug list, but the developers haven’t found a resolution for it yet. We’re hoping we’ll be able to address it with the next major update, when we’ll be doing some overhauls of the framework and editor.

There’s not currently a way in Scrivener to change the ruler settings for an element after the fact an apply that to the existing text, during compile or otherwise, so this would need to be done afterward in Final Draft as you were attempting. I’m afraid I’m not terribly familiar with FD, but it looks like this could be done: kb.finaldraft.com/article/1001/40/

Have you tried that? It seems a bit different from just applying a template, if I understand what you did earlier, so it may be worth a go.

Thanks for this suggestion, which unfortunately hasn’t solved the problem, but has clarified it. The FD article describes how to make changes to an FD element. The trouble is that when I follow the steps in the article, there are no changes made to the file.

It seems to me that this may be because Scrivener is creating an .fdx file with illegal settings:


This screen shot shows what happens when I inspect the Action element in Scrivener’s .fdx compile output. FD does not allow a right margin setting of more than 8.00" - but Scrivener’s .fdx has a 9.00" right margin. The consequence of this is that FD does not recognise this element as a legitimate ‘Action’ element, and so does not include it when instructed to reformat all action elements.

Ah, hmm. The elements are recognised by their ruler formatting, so since you’ve changed that in Scrivener, Final Draft doesn’t recognise them. You might be able to get around it another way–create the template in FD first and then open the compiled document into it, but I’m not exactly sure how that would go. It’s probably not going to help in this case anyway if the template won’t allow the right-indent setting that you’re using in Scrivener.

Maybe try changing the font size instead of the ruler?

Ok, tried loading the FD template first, and some variations of this, but the problem persists: FD won’t treat anything with a right margin of 9.00" as a legitimate element.

So I’ve tried reducing the font size in Scrivener. What I need is screenplay standard, which is about 60 characters to a line. 10pt at 115% zoom is about right, but is too small on the screen for me.
1.jpg

But if I increase the zoom then the pitch changes! At 120% it’s getting 57 chars per line.
2.jpg

And at 125% it’s changed again, 54 per line, and it looks weird - stretched out.
3.jpg

Very frustrating! Maybe this is another manifestation of the original bug.

I’m surprised Scrivener still has this bug after all these years, given that page formatting is so critical for screenwriters. How do others cope?

I’ve now tried resetting my Windows settings to 96dpi, instead of the 120dpi that seemed to be at the root of the problem in the first place.

But now most of the interface fonts are too small to read in Scrivener. I can change most of these in Tools/Options/Appearance, but whatever I do with the font settings for Document Notes and Project notes seems to make no difference. How do I change these font sizes?

…and now I’ve noticed that Courier isn’t displaying at the right pitch when I use the Windows default 96dpi screen resolution either.

2.jpg
Is this just me? Is there something I can change to my display settings to get this right?

Well, that was a day out of my life I’m not getting back, but here is a work-round.

A page that has 8" of text space in Scrivener displays about 60 Courier characters - the norm for screenplays. [edit - that is, with my display settings. As described above, it looks like Scrivener displays Courier at widely different pitches with different display settings].

To output to Final Draft:
In the compile settings, set the left and right margins on the page settings dialogue to zero, and compile for Final Draft. This outputs a file that looks pretty weird in FD, but all the elements are recognised as legitimate by FD, and so you can apply an FD template to convert it to the correct format.

Phew! :unamused:

I’d still be interested in an answer to this please. :confused:

I’m glad you’ve found a workaround!

The font settings for document and project notes are similar to the editor, in that they only affect new notes, since these are rich-text areas. You’ll need to use the standard select-and-format method for existing notes. Copy/Paste Formatting may be helpful here, especially if you’re changing more than the font size. I also keep a formatting preset of my usual document notes style to easily clean up any text I’ve pasted in with incorrect formatting (for cases where I don’t want to use Paste and Match Style).