Compiling to Final Draft

When I compile my screenplay to Final Draft format, Scriv successfully assigns the right FD element to most of the script - eg characters, dialogues, action lines, scene headings. But there are some it misses - eg act headings, script titles, end of acts. So each time I compile, I have to manually change these elements in Final Draft.

Are these transitions hard-wired into Scrivener? Is there a way I can set up either Scrivener or Final Draft so that act headings etc are automatically assigned the right element format in FD?

You can adjust the formatting for elements by going to Format > Scriptwriting > Script Settings… This will change the format going forward; for existing text you need to update, there’s not yet a way to make a global conversion, so you’ll have to reassign the element to each outdated element. This is probably easiest via the shortcuts to call up the element menu from the footer and then select the element.

Updating the script settings will change them for that particular project; from there you can also choose to save them for use in other projects or export them if you want to also copy to another machine.

I don’t think this answers the question. I’m not asking about changing elements within Scriv, but about how Scriv assigns FD elements when it compiles to Final Draft.

I can’t see anywhere on Scrivener’s Format > Scriptwriting > Script Settings panel where it assigns a Scriv element to a FD element.

Hi - any response to this?

To clarify the problem… here is what the file looks like in Scriv:

105.jpg

And then I compile to Final Draft (.fdx format). This is what the file that Scrivener produces looks like in Final Draft (you’ll need to scroll down to see it):

Problem 1
Each line is assigned to a Final Draft element. Some are correctly assigned (see below) and others are not. How does Scrivener decide what Final Draft element names to assign to each line? Is there a way that I can get it to assign different element names (eg Teaser, Series Title)?

SERIES TITLE >>> incorrectly assigned to Action. Line should be indented.
Episode Title >>> incorrectly assigned to Action. Line should be indented.
TEASER >>> incorrectly assigned to Action. Line should be indented.
FADE IN: >>> incorrectly assigned to Scene Heading, but doesn’t matter as formatting is ok
EXT. LOCATION - DAY >>> ok, assigned to Scene Heading
Scene description and plenty of action goes here. >>> ok, assigned to Action
CHARACTER NAME >>> ok, assigned to Character
And finally she gets to say something. >>> ok, assigned to Dialogue

Problem 2
Scrivener puts half a page of empty space at the start of the file. Why does this happen?

Scrivener is set up to read a Feature Film screenplay and what you want is a TV format-- which is entirely different. Even in Final Draft, one has to select a TV Template for that result.

You will have to modify the Scrivener Feature Film screenplay template to suit your TV format.

Thanks, Marta.
Where exactly do I find that, and what is the filename?
I have screenplay templates (.xml files) in C:\Documents and Settings*username*\Local Settings\Application Data\Scrivener\Scrivener\ScriptFormats, but none of them have the words ‘Feature Film’ in their names.

What I mean is that you would have to take the Scrivener Screenplay template and modify it yourself to suit your TV show’s specs.

To do that, open up the new screenplay project, save as a new template–such as TV Screenplay or whatever you want. Then assign keys strokes.

Check the manual on how to assign keystrokes, as I’ve never had to do that.

I haven’t made a template in a while, so I apologize if that’s vague.

Perhaps the Scrivener folks can explain better.

Thanks, Marta, but I’m not sure this is the right solution, since I am already using a modified Scrivener template, with personalised keystroke assignments. And how does keystroke assignment affect how Scrivener assigns FD elements when it compiles?

PLEASE could someone on the Scrivener team have a look at this?

Sorry for the delayed response; I thought I’d replied to this one a while ago but apparently I never actually posted it.

Keystrokes don’t affect the elements; they’re entirely for use in Scrivener. What matters is the formatting for the elements, as this is how Scrivener determines what element each paragraph is. For RTF compile, this is how the elements are IDed when imported to other programs, but I’m not clear on the specifics of how the information is passed when compiling directly to the FDX format, so I am checking on that.

What Marta suggested, I believe, and what you may have already done, is creating a new script template via Format > Scriptwriting > Script Settings… matching the formatting of the various elements to the formatting you’d see in Final Draft. This is what I inarticulately attempted to explain in my earlier post, that the elements in the script setting you’re using in Scrivener must have identical format to the Final Draft specs in order to be recognised. It may be that this is only necessary for scripts you’ve imported into Scrivener from Final Draft, however, and there’s another factor in determining the formatting going out, and that’s what I’m checking on. I don’t know what aspects of the conversion Scrivener handles when compiling to FDX, so I’m not certain where the error lies at this point and how therefore to correct it.

All right, it looks like there’s a bug whereby Scrivener is forcing the default Final Draft screenplay elements/formatting on the script when compiling to FDX, regardless of the script settings for the project. It should be passing whatever custom elements and formattings you’ve created in the project to the document stylesheet for FDX. I’ve filed a bug report on it with a sample test project to demonstrate the issue, so hopefully we’ll be able to get this fixed soon. In the meanwhile, would it help to use different text colours for various custom elements so that when brought over to Final Draft, they’d at least be easily identifiable for quick selection and conversion to the proper elements? (You’ll need to deselect “Remove text color” in the Transformation options of compile.) Not a great solution, but maybe it would give a little boost.

Ok, thanks for clearing this up.
What about:

Is this the same issue or something else?

Whoops, sorry I missed that. It looks like the page padding is getting picked up from non-FDX compile settings, so that’s a separate bug. Try selecting “Original” from the preset dropdown at the top and then compiling to FDX. (Or, if you’ve modified a lot of compile settings, switch to RTF as the format, then in Formatting, select the document row, click Modify and set the page padding in the upper right to 0. Then switch back to FDX to compile.)

Sorry - which is the ‘document row’'?

Whenever I make a change, I get a warning message: When the checkbox option “Override text and notes formatting.” is not checked, text formatting will be ignored. - do I just ignore this?

You can ignore the warning; the page padding takes affect whether or not you have that checked, so it doesn’t matter here. (And of course the page padding shouldn’t be affecting FDX compile at all.) At the top of the formatting pane is the element table where each row indicates a document type and level matching what you see in the binder. At the simplest, this is three rows: folders, document stacks (i.e. documents that have subdocuments), and single documents. I’m assuming your scenes are all of the last sort, single documents in your binder without subdocuments, but take a look at your script documents in the binder to confirm this and adjust the appropriate types in compile. You can also just go through all the rows here and check that none of them have page padding to be safe.

Marvellous, it works, thank you.

Phew! Sorry about all the hassle with this and my earlier confusion.

I don’t know if this will work for you but I found a list of tips through the Scrivener Facebook page

Some tips apply only to MAC. but the one below-- which may apply to you works on my system

To use one of Final Draft’s script formats, choose “Load from Final Draft FDX file…” in the Manage… button at the bottom of the Text > Script Writing > Script Settings panel, & select a FD8 file from which you want to read the formatting.

I then went through all the settings, making sure that the font, alignment etc were to my specs, and adjusting the ones that were not–some settings had an MS Shell DLG 2 font (? )

Hope that helps
script settings2.jpg
script settings.jpg

Ok, I tried this.

I loaded a set of script settings from an fdx file, and all the elements showed up in my Scrivener file as in your screenshot. I then did a compile to fdx, but nothing changed. The file that Scriv exported only contained the much shorter list of fdx default elements.

Am I doing the right thing?

Yes, that would be correct except that the bug is ignoring all the custom settings and using just the Final Draft default screenplay elements, so although they appear properly in Scrivener to match your FD template, they’re not making the transfer during compile. Once the bug is corrected then it should identify the elements with their custom formatting and pass all that on to the FDX.