Compiling to HTML

Posting this here as I’m not certain if this is intended, or indeed a bug.

When I use the Copy as HTML command or spaces between paragraphs are removed in the output.

For example in Scrivener I have:




Using Copy as HTML I end up with:

Paragraph Paragraph Paragraph

Is this supposed to happen?

Hi StaceyUK,

I get that same results when I copy as HTML and workaround it by typing a SHIFT+ENTER to create a blank line between paragraphs instead of just ENTER. This will display properly when compiling as well.

This is caused by the output from Scrivener and not your computer’s settings.

Thanks, Chris

Thanks Chris for the tip!

That will insert line breaks by the way, or br elements, so keep that in mind if you intend to keep the HTML agile and easy to style with CSS later on.

Sorry, Stacey, I started investigating this and then forgot to reply back over here. I’ve got looking into the Copy as HTML and the compile to HTML commands on the list, as there are a few tweaks that do need to be made here, including adding the proper styling to have the line spacing respected.