Compiling to Word - some paragraphs don't indent

I’m working on a long document. When I compile to Word, some paragraphs don’t indent. When I do a zap gremlin in Scrivener, I can see by the markup that some paragraphs don’t have the indention symbol. I’ve tried compiling in various different ways, but it’s always the same.

Example: “Otto” should begin a new paragraph. It does in Scrivener, but when compiled to Word, it looks like this.

There wasn’t much to buy in Luck, but when something went up for sale, Sheryl was first in line. Otto had grown up poor, sharing a bed with two

What it looks like in the Editor has nothing to do with the way it looks after running Compile. Scrivener isn’t a wysiwyg word processor like Word.

Have you done the interactive tutorial, the part covering Compile?

The forums don’t display extended white space. From the look of your example vs. your explanation, it appears that “Otto had” should start its own paragraph, but instead, it’s just a continuation of the previous paragraph.

Use the “Show Invisibles” menu item to display all of the control characters and spaces to see what’s different about that paragraph vs the previous one. From there, you could copy whatever control characters are causing that issue, and do a project replace, pasting that into the “search for” field, and replacing it with a “return” character.

What is the indent symbol that you refer to? There is really only one that matters (or two, if you count block indent) on the left side of the ruler. These controls should never be missing, but they could indeed be dragged all the way to the left, so that the paragraph has no indents. There is an illustration of what I’m referring to (Fig. 15.6), and how the text reacts to the various symbols on the ruler, in §15.5.1, The Ruler, pg. 394 of the user manual PDF.

Beyond that, there is one thing to check for with invisible characters shown, and that would be paragraphs ending in a curly arrow symbol (:leftwards_arrow_with_hook:︎) instead of a pilcrow (¶) symbol. The latter is your standard paragraph break mark, the former is for creating hard line breaks within a paragraph. It’s an uncommonly used tool, but can be useful for creating informal lists, captions and such. These are lines within one paragraph, so subsequent lines (or what you might be conceptualising as another paragraph) will not be using the first line indent setting, since they are not the first line.

Thank you for your help. I am attaching screen shots. The tan image is Scrivener, with “show invisibles.” The white is Word. I can see that the paragraph marker is missing in Scrivener, which is why there is no new paragraph in Word, but I don’t know why it’s missing. When I’m writing in Scrivener, I always hit return to start a new paragraph.

Thank you. I looked at 15.5.1 in the user manual. I’m wondering if the problem I’m encountering is with tabs/indents. When I write, I might be hitting return/tab. I write very fast, so it’s hard to catch. Here is a screenshot of my tab/indent settings in this document.

Have you tried positioning the cursor at the end of the line and pressing return? It looks to me as though you have a tab character in the middle of the line, which if there are no further tab stops at that horizontal point, will jump to the next line.

By the way, using the Tab key to indent paragraphs isn’t the best way to handle this, and can cause weird stuff like what you’re running into with how different editors display them. I’d recommend using the ruler tools to establish indent formatting, as referenced above. You can run into all kinds of problems down the line (your publisher is going to be running a macro to strip all of this out of the text because it messes up formatting). If you’re self-publishing, you’re likely going to run into those problems yourself. They can get in the way of real indents being applied by templates or compile settings, get lost entirely when compiling to HTML-based contexts (like you witnessed in the forum here, but more importantly, in ebooks and online posts). Much better to have a simple formatting rule that governs the shape of your paragraphs rather than having to type out the shape yourself by hand.

We have a few tools that can make it easy to switch:

  • The Edit ▸ Text Tidying ▸ Strip Leading Tabs command.
  • You can then adjust your formatting globally to be properly indented, and convert your text in bulk to the new look. Hint: if you find moving the little elements around on the Ruler to be difficult (I do), then use Format ▸ Paragraph ▸ Tabs and Indents…, where you can just type in the measurement you want (like 0.5in) by hand.

On Update:

Yeah, it looks like you’re already heading in the right direction, and found some of these tools. The place where you want to set up the indent itself is the First line field. That should be “0.5 ins”. The tab stop can be whatever, since it wouldn’t be used.

I hear you on the habit though, just keep in mind that handy Text Tidying tool can clean things up after an intense writing session. I often use the one that cleans up double-spacing, since I tend to hit the spacebar too much when I’m in the flow. :slight_smile:

This is so helpful! I’ve been struggling with the tab/indent problem for years, but I didn’t know what it was. I selected all in the manuscript and selected Text Tidying/Strip Leading tabs. Then I went to Format/Paragraphs, put in .5 for the first line indent, and made all tabs 0… See screenshot.

However, the manuscript is still showing random arrows – which I think represent tabs? See screenshot.

Yeah, that’s what those arrows are—they show where the tab character is—it’s a “physical thing”, just like a visible letter, in your document. The arrow signifies where that character is.

The command to strip out leading tabs does just that and nothing more. If the tab is on a line by itself, or at the end of the line, or in the middle of a line (as one of your previous examples showed), then it will remain.

Since this is a character, you can select it and copy and paste into the Find window to search for them. I’d recommend doing that on a line by line basis to make sure the edit to remove it is what you want. A bulk search and replace might do unintended things.

Okay. I will. Thank you!

Hello, Amber. I have gone back this discussion several times, and I want to touch base with you again, as I revise the same manuscript, to make sure I have set the ruler correctly. No tabs! Please look at this image and let me know if this will create the correct formatting in a novel manuscript – indented paragraphs with no spacing between them. I want to create a preset that I will use for every book. Thanks so much for your help.

Yes, this is fine—there isn’t really anything you can do here in your default formatting settings that would mess up the compiler. You can choose whatever font and paragraph formatting you prefer. How things look in the end can be entirely left up to the compiler. The main issue you were running into before wasn’t a problem with formatting, in a rulers & fonts sense, but errant text entered into the editor to create formatting with spacing characters.

Thank you.