Compiling

Trying to set up a custom compile for a novel. I have added an ‘unassigned’ section type because several pages of front matter and back matter need to come into the compile unchanged. When I try to assign that type, Scriv compile tells me I have only sections and chapters. see 2 attachments.
I need to do this for both doc and electronic.


When you say you’ve added an “Unassigned” type, do you mean in Project ▸ Project Settings…, under the Section Types tab? What I see here in the screenshots are the Layouts provided by the format you are creating, but in the one that shows which section types the project itself has, there is only “Chapter” and “Section” as you put.

Here’s what I would do:

  1. In Project Settings: Section Types, create a type called “Front & Back Matter”. That’s all I’d do there—I’ll assign it manually to items rather than setting it up as a default in the second tab.
  2. Back in the binder, select both the front matter and back matter folders at the top level.
  3. Right-click, and from the “Section Types” submenu, set the “Default subdocument type” to what was created in step one.

Now all of the documents in all of the front/back matter folders should be automatically assigned to this type. I can now assign them to the “Unassigned front back” layout in compile settings.